EZCad 2 compactible/clone board


I recently purchase a used laser which came with a JCZ clone board, identical to the person in this post:

As with this other post, the vid/pid is 9588/9980.

I am on linux and the laser does not seem to be recognized. The shell output clearly seem to iterate over it but it does not seem to do anything with it:

Found port: PID 60000 VID 4292
Manufacturer: "Silicon Labs"
Product: "CP2104 USB to UART Bridge Controller" on "ttyUSB0"
attempting connection... 115200, DTR setting: false
attempting connection... 115200, DTR setting: true
Found port: PID 0 VID 0
Manufacturer: ""
Product: "" on "ttyS0"
attempting connection... 115200, DTR setting: false
attempting connection... 115200, DTR setting: true
Vend: 38280 Prod: 39296
Empty filename passed to function

I also gave it a try on windows 10. I was able to replace the driver with WinUSB with zadig, but lightburn still does not seem to recognize the laser.

Any tip on how to proceed would be appreciated !

Quick update, after installing and dei-nstalling the driver a number of time, I managed to get it working on windows, but still nothing on Linux.

Quick update …

I managed to kind of get it to work on linux…

When working on windows, I realized the the board start with enumerating as 9588:9980 and as soon as it is connected, re-enumerate as 9588:9899. I think the driver or software is loading the firmware.

If I first connect it to windows, then re-connect it to linux without re-starting the laser, everything works.

Does anyone have a solution to get this to work all on linux ?


I am having the exact same issue. I have tried a fresh Ubuntu 20.04 LTS install and the newest Lightburn and it detects nothing. I made the permissions changes in udev, but the issue is the VID:PID.
I even tried running as root out of frustration to make sure that it wasn’t a strange permissions issue.

In lsusb it shows the same ID as yours: ID 9588:9980

dmesg shows:

[ 8094.603155] usb 2-2: new high-speed USB device number 16 using xhci_hcd
[ 8094.751420] usb 2-2: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[ 8094.751426] usb 2-2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[ 8094.751429] usb 2-2: Product: USB 2.0 Hub
[ 8094.752622] hub 2-2:1.0: USB hub found
[ 8094.752667] hub 2-2:1.0: 4 ports detected
[ 8095.139270] usb 2-2.1: new high-speed USB device number 17 using xhci_hcd
[ 8095.339373] usb 2-2.1: New USB device found, idVendor=9588, idProduct=9980, bcdDevice= 0.01
[ 8095.339379] usb 2-2.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 8095.539074] usb 2-2.2: new full-speed USB device number 18 using xhci_hcd
[ 8095.759525] usb 2-2.2: not running at top speed; connect to a high speed hub
[ 8095.760273] usb 2-2.2: New USB device found, idVendor=3689, idProduct=8762, bcdDevice= 2.00
[ 8095.760279] usb 2-2.2: New USB device strings: Mfr=1, Product=1, SerialNumber=0
[ 8095.760282] usb 2-2.2: Product: USBKey
[ 8095.760285] usb 2-2.2: Manufacturer: USBKey
[ 8095.766240] hid-generic 0003:3689:8762.0005: hiddev0,hidraw0: USB HID v1.10 Device [USBKey USBKey] on usb-0000:00:14.0-2.2/input0

I did end up installing EZCad on a old Windows machine and I was able to burn stuff, but it shows up in Device Manager as 9588:9899. I also tried what you suggested, swapping after starting on Windows, but that did not work for me, it still shows up as 9588:9980 in lsusb.
I see in the drivers folder that the .inf has both product IDs:
%JCZUSBDEV%=Install_LMC, USB\VID_9588&PID_9980
%USBLMC%=Install_LMC, USB\VID_9588&PID_9899

I did not try the Windows version of Lightburn, since that laptop is old and out of date, so I did not want to connect it to the Internet to get the trial to run.

If you or anyone else has any ideas, please let me know. I have a fair amount of Linux experience, so I would be glad to work with anyone to try and debug this.

I already run my diode laser on Lightburn in Linux, which I love! I just bought the fiber and it would be a major bummer if I have to go back to Windows/EZCad.


Hi Dave,

I lied a bit, when I said switching, I actually just do a usb redirection via qemu. This mean the board is actually always powered via usb.

My experience with usb is limited, but I might do some reversing on driver to see if I can figure out how the firmware loading is happening and see if I can replicate it on Linux.

I created a simple tool that extract the firmware from the windows driver and load it:

Let me know if this work for you

1 Like


You are amazing!!! I tested your script and it works perfectly!!! I am able to use my Fiber in LightBurn on Linux!

I really appreciate you responding so quickly and I never expected a solution that fast, but WOW!
I am in awe of how you figured that out so quickly and effectively.

Thank you very much,


I am happy that I help … that was actually quite fun to play with …

1 Like


It is a great help. I created a bash script to run the your Python script and then start LightBurn, which I then added as a desktop shortcut. So, it works as it normally would.

I am not sure if your fix can be incorporated into LightBurn, but hopefully this will help others in the same situation.

Again, Thank You!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.