Falcon2 Pro won’t connect on MacBook, Works on PC

Just got my Falcon2 Pro 60w and I cannot get it to work with our MacBook which is next to it. No problems with the Windows laptop with the same cables. Have tried different adapters, different ports, different c to c cables, rebooted etc. It saw the laser and let me add it in Lightburn when I first connected to it, but I can’t control it. Console just says waiting for connection and if I click “show all” it repeats G0 over and over. Currently if I remove the device and try to re-add, it doesn’t see it. But then if I restart Lightburn it is still there. Any ideas?

Signed an absolute hater of Mac.

This thread should help.

Out of curiosity, if you HATE Mac and have PC available, why are you using it and not PC? Former Mac hater here.

Solved it. I had the port selected as Auto and apparently had to select the specific one. Working now.

My wife’s Mac is at the desk here where the laser is. My Windows laptop is my gaming machine upstairs so it’s not practical to use it with the laser.

Signed still a Mac hater.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.