Firmware update problems

I tried to update the firmware for lightbuen and now my laser won’t turn on. Need Help

It would help if you write what you have done and what you are trying to do now.

I did everything that was online to update it, push the power button and rest button copy link form downloade ling (twice) still not powering on.

sorry for the typing errors.

Opened lightburn setup laser with grbl but does not connect to com3 like before.

so you updated Lightburn, not the firmware?
Try to add your device again with the “Find my Laser” option?
Did you check in device manager if it is still com 3 ?

I tried to find my laser and nothing comes up. I can’t connect to com3.

Since your firmware scewed up my laser you should send me a new motherboard!

No way that an update to lightburn screwed up your motherboard. Don’t be ridiculous. Guess you are part of the everyone owes me something crowd. Have you tried to figure out if your computer even has com 3 available? If so, try a different com port for pete’s sake. Tired of everyone thinking they are owed something.


Just to keep track of the terminology, Firmware is the piece of "operating software that is in your laser machine. Software is a program that is used to perform tasks you create with the help of this software.
No software can change your firmware without you determining it. Most often, a special piece of installation software from your machine manufacturer is used for this.
If your machine does not find LightBurn to communicate with, it may be due to either a problem with LightBurn or with your machine.
have you tried to install the latest version of LightBurn that works for you? Have you read a bit in the forum regarding similar problems and possible solutions to them?

Then why is it when I look for an answer a MORON like you comes up?

Dude, whatever meds you’re on, your dosage clearly isn’t right.

The moron would be someone calling for a software maker to replace your motherboard because their firmware (which they do not provide) screwed up your motherboard after you installed their software. You would think the post below mine would have summed up what you have, but…guess not.

does your mainboard look alive or is it dead?

Did the same thing. Laser stop working. Went back to the old bin file works like charm again.
Not doing laser updates. Pain in the but tec support did not help.


If you updated the firmware on your board, that has nothing to do with LightBurn itself - it’s entirely a function of the board. Ortur firmware is a bit fussy about how it works - you have to unzip the file first, then copy that unzipped binary to the board, then reset it.

This may help. I had similar problem so this is what cured mine. First plug your laser into power and your machine should have a small red light on the control board. Now put the laser into firmare update mode. Press power button for 5 sec. them while holding the power button in press the reset button once and then release both buttons . Look in your computers drive panel and you should see your laser listed. Make sure you unzip the firmware file and then drag it to your laser dive file. wait for the update to complete and power off the laser. Power on again and I’m sure it will all be working. Good luck.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.