Flood Fill Werid lines issue Galvo Fiber

im having a weird issue when using flood fill the laser leaves very clean lines and looks like differences in power output, but when I use regular fill all shapes at once or fill shapes individually I get no weirdness. only issue with that is if I use fill all shapes individually and have it set to run a layer more than once it will do each shape back to back until it reaches the layer run number instead of filling the entire layer shape by shape once per run number if that makes since. and fill all at once is much slower.

Flood fill does not work well with galvos. This comes up quite a bit on the LMA forum. I think the flood fill was originally developed to optimize gantry lasers, and was there long before LB for galvos was available. Just guessing, I think it messes with the timing or backlash of the servos on the mirrors. Those little guys are moving at warp speed, and just don’t like the large angled diagonal jumps. Possibly none of the TC’s are designed to compensate for it, but that is speculation. (Along with everything else past the first sentence)

Agreed… why would you enable flood fill on a galvo…

:smile_cat:

For the reasons stated above in my OP I am trying to get it to fill all the shapes individually and have it finish the entire job once per number of times I want that job ran instead of it filling each shape say 50 times if I have it set at 50 then moving to the next shape and doing it 50 times.

That makes sense so how can I get it to finish the entire layer once then run the entire layer again without having to set it to run once then starting the job over and over? Because if I set it to 50 it does each shape 50 times one by one then moves on to the next shape? maybe mine does that because I have minimalize travel enabled under optimization settings I’'ll tinker with it when I get home.

So do you want it to fill shape 1 once, shape 2 once. Shape 3 once, then back to shape 1, or do you want to fill shape 1 50 times, then shape 2 50 times, then shape 3?

If you use the preview, you can change the optimizing around and see the results without running it on the machine…

The most important and ignored part of Lightburn is the preview… IMHO…

:smile_cat:

1 Like

When I use preview it shows each getting ran once no matter my settings ill have to check when I make it home to be sure.

Shape 1 one shape 2 once shape three once then repeat that the number of times I choose.

Your profile doesn’t list a fiber… which do you have?


With a fiber you have this option…

If you have it as 1, 2 then 3 with single passes for each layer, you can reset count enable repeat and the number of iterations.

If it’s set for 4, then it will run your setup layers 4 times… engraving 1, 2, then 3 as a group four times.

Is this what you are after?

This happens quick, so you can slow it down on the bottom left and also manually drag it to simulate speed to see in detail what it’s doing…

:smile_cat:

1 Like

I have a 100watt bwm tech mopa and yes this is the effect that im after im gonna give it a try

1 Like

If that doesn’t quite work I think if you put each shape on it’s own sub layer and then ran the repeat you would be good.

umm This is one of the things that I did that I wanted to use that method if I were to put each shape on its own layer im sure id be dead before I finished lol

1 Like

Like your coin… I assume it’s one similar to these I get from Amazon?

Do you mind passing on the setting and process you used…? I’m sure anyone with a fiber would appreciate other workflows.

Here’s a Vader Mayan calendar

Not sure I’m following you here, but do you know about sub layers…

It uses the same graphics, but acts like a separate layer…

I’ve found it very helpful for the fiber.

I think these people know a bit about sub layers…


Did the post about repeat fix the issue?
If so, please mark it solved…

Good luck

:smile_cat:

Sorry for not sharing the, to begin with this was 2000 SP 200ns 50hz @ 40% power on a jpt 100watt mopa with 110 lens in focus ran the job abut five or six times but used low power to avoid burning and having to run clean up passes this is right off the laser no plosihing and these coins are 50mm with 3mm edge qualite of brass is much better than anything on amazon with brass blanks. I have thess for sale if anybody wants em blank.

Is 40% low power?

Maybe that’s my issue on some of these… I have a 60W and I’m using about 20% and more passes…


I can’t hardly afford Amazon brass blanks…

:smile_cat:

40% through a 110 lens is a lot of power density with the 100W I would think. Especially with a quality lens.

as far as I know on my machine its low lol doesnt burn like 60 would

‘Flood Fill’ when using a galvo is the equivalent of ‘snake hatch’ on EzCad, and was highly requested because it causes many fewer jump delays and leaves the beam on. Even doing a large circular frame, like a hollow circle, using flood goes really fast, and using normal fill wouldn’t because it still has to move the mirror back & forth to jump the gaps in the middle. And, like on CO2 or diode, it can cause gaps if the machine isn’t really dialed in. For any undesired “leftovers”, you can do a fast clean pass to address that. :slight_smile:

I have seen that in the LB documentation, flood fill as a comparison to snake hatch, but respectfully, having used ezcad before LB for galvos came out, there is something different between the two programs that makes flood fill leave artifacts behind where snake didn’t. If you look at the OP’s image, it’s not just start and stop TC’s, it appears to change the entire zone’s tone.
Although it does speed up designs with a lot of white space, if you then need to run cleanup passes to deal with the artifacts, didn’t really save time.
Anyway, as someone else noted, don’t really need it on a galvo with jump speeds in the 4000mm/s range.