Fonts; SHX and system

I recently added the SHX fonts posted by Ash in Nov. 2020. Everything works very well, but I can’t find a way to have access to my regular system fonts as well as the SHX fonts…

I’m almost certain when I first added the SHX fonts, they were mixed in with the system fonts which was annoying, so I somehow switched the system fonts off. Now the only way I can get to system fonts is by removing the SHX path…! Any ideas about how to remedy this, or do I just have to switch the SHX path on and off as needed?

Running Lightburn on Mac at the moment, but also use PC now and then.

Configuring the SHX fonts folder and adding fonts there should be purely additive to your system fonts. This is what I think you were seeing initially.

I’m not sure how you would have done that. I suspect it wasn’t something within LightBurn itself.

This is not the way it’s intended to function. And I’m curious how this could have occurred.

I’m tempted to say to try delete your entire prefs folder but depending on how you disabled the system fonts the first time I’m not sure if this would fix it.

Can you send a screenshot of what your font pulldown looks like?

Also, what is the “Default Font” set to in Device Settings?

1 Like

Rick uses the SHX fonts quite a bit.
this is worth review: Unable to access SHX fonts

I also like his clever idea (in post #9) where he changes the filenames to start with “1_…” so the new fonts all land in the same place.

1 Like

Right click on the font dropdown and you should see options to show/hide system and SHX fonts
image

4 Likes

Nice. Never knew this existed.

1 Like

I don’t use the SHX fonts much so I renamed them all so that they have a double zz at the start of each font name, so they are always at the end of my normal fonts in the drop down box.

2 Likes

Fantastic; many thanks Adam! I had a feeling I was missing something very simple! :smiley:

2 Likes