Frame function NOT WORKING half the time

PLEASE PLEASE for the love of god…FIX and QUIT screwing up ANYTHING to do with the frame function…just how complicated can this be?? FRAMING things IS NOT COMPLICATED…and for atleast a year now there has been no frame speed control, changing the values under MOVE does NOT do squat anymore…once upon a time LB was great, now its ALWAYS a PIA JUST to FRAME SOMETHING…geeezzzz…it just gets worse and worse the more yall screw with it, 10-15 updates ago it was working flawless, now its getting to be a pia just to get it to work…WHAT THE HECK IS GOING ON??

i don’t know what is your problem but… last version with me works like a charm

We have not touched anything to do with the frame functions for DSPs in a very long time.

What kind of computer do you have? Is it a Mac, by chance? It also seems like you’ve not posted about this before, at all - how are we supposed to know there are issues if you don’t speak up?

I’ve been having issues with my Topwisdom machine since upgrading to LB 10.01 and 10.02 (was running 9.24 with no issues). Haven’t bothered with 10.03 yet.

I can use the frame function once after connecting the machine, then it doesn’t work again which is a real pain as often you need adjust the workpiece and check the frame again but it does nothing.
On occasions I’ve managed to get it to frame a second time but only after disconnecting the usb cable, turning the laser on and off and generally dicking around with it. Even then it can be 5+ seconds before the laser frames.
Happens every time - not intermittent.

My Ruida machine works just fine, only my Topwisdom with issues.
Also, since upgrading from 9.24, my Topwisdom does not recognise the laser on Auto Port setting - I have to manually choose the port from the drop down.

Topwisdom TL410-C
Connected via USB cable (doesn’t have ethernet port on the controller)
Windows 10

1 Like

Win10, it started this right after an update, been months ago now, i just figured the next update would fix it…maybe it is my pc, but its healthy and no issues running any other cad/design programs etc…no issues at all other than the frame function, it only randomly works, becomes unresponsive, lags etc…i’ll look into my pc’s performance alittle closer…sorry for being a dick…i own it

yes sir…exactly what mine is doing…click it 2 or 3 times and it might work once, or frame 2 or 3 times…like its lagging out, locking up etc…but yes, mine started not working around that update version aswell…glad its not just me, theres an issue somewhere with that update era for sure

mine also started acting up “move to laser position” the part does not move to laser position unless i click it a few times, at times it just moves to center of the screen when the laser position is nowhere near there…smh…the 9.xx version days were ALOT better than this 1.0.xx days

FoxAlien is a GCode machine, much different than a DSP controller.

I’m traveling until Friday, but I’ll hook up a 410 this weekend and see what I can figure out.

If something like this happens in the future, please tell us right away. It seems like everyone assumes we’ll hear about it and fix it in the next update, and we end up not hearing a peep until 4 months later, when it’s much harder to backtrack and pinpoint.


I can confirm I have seen the issue on mac, but not in windows. My friend downloaded latest version yesterday and the frame function was a DISASTER. It’s really frustrating to teach someone how to use the laser and lightburn when this bug is occurring.

From someone who has a good amount of experience coding, it may be related to other shapes within the bed area that have output switched off, but that is purely based on 1 situation where deleting all of the other objects not to be lasered let frame work correctly for the output enabled layers I wanted to frame.

Worth noting, is that I did not check if frame was the issue, or if the cut job would also be wrong too.

I will save the file in question (if i can reproduce) and upload if someone from lightburn thinks it will help.

To over complicate things more, the Mac version is newer and we are using USB serial on the MAC. Both machines will be using ethernet soon and I will upgrade windows lightburn to to see if the issue is isolated to MAC.

Ruida 60w blue OMtech lasers (2 of them)
Windows Ethernet Only so far (frame works great)
Mac USB serial only so far (frame has issues)

are you USB serial, USB packet, or USB ethernet? what version?

my windows machine has never had the issue 9.x.x.x and ethernet. I have not tried on windows yet.

Thanks, will do…i think the frame issue is related to the move and laser location…cant change frame speed etc, sometimes laser position indicator fails to move with movement, then after you move it again it’ll jump to correct position…if that info helps…

i have never used frame or positioning controls within lightburn, only on the ruida itself, and we are still seeing the issues on MAC. I will have more time to troubleshoot this weekend and report back.

You could be on to something with other objects in the bed area.
The file that I run almost exclusively on my topwisdom is a rectangle the same size as my workpiece with the output turned off.
The design I am engraving is positioned in the bottom corner of the rectangle. I have guides screwed to my bed at 0,0 so I put my workpiece against the guides and the engraving is always in the right place.

Scrap that - I tested with another file which has no layers turned off and still same problem.

I’m about to finally move from a stable 9.x version to the latest DSP version (just upgraded this morning) and before I install it, I wanted to know if any progress has been made on working out what this issue is?

I have a lot of cutting to do over the next week or so, and I’d rather stay in 9.x if this issue is going to trip me up.

I’m on a Mac, connected via USB.

Thanks :slight_smile:

MacOS has always had issues with the FTDI driver and has been hit & miss. I haven’t made further progress in tracking down the issue, but we are still poking at it. If you upgrade to the latest and it doesn’t work properly, you can just install the previous version. (Go to Help > Quick Help and notes, and click the About tab to see which specific version you’re on)

1 Like

Thanks for the quick reply Oz! Yeah, it is hit and miss. Sometimes a Mac reboot is needed, and sometimes, just a re-plug of the USB cable and a re-initialise. I’m kinda used to those issues, and understand it’s not Lightburn at fault there, but having the framing feature not work reliably is gonna be a “new kind of painful” :slight_smile:

Love your work and dedication mate!

1 Like

Not seeing the issue on ethernet for mac yet. We’re actually wireless, the machines plug into a wireless router that’s been converted into a wireless bridge/extender. Never had an issue on windows, no issues on mac yet.

On Ethernet you won’t have an issue - the problem is somewhere in the serial comms, either on our side (which is still a possibility, I admit), or in either the framework we build on, the driver, or the hardware. I’m still trying to nail down what’s happening.