Frame function not working properly/ origin for work

Hello,
I am having an issue with the framing tool, and/ or the laser start position. I have a jig set up to engrave. my lasers origin is off so i put the jig on the coordinates .6 for x and 3.5 for Y. This is my machines true (0,0) if that makes sense. when i try to frame a new job it will frame the last job that i did, and not what is currently on the grid. I usually use temp files and overwrite the name. Pre-update this worked flawless. The main call for concern is that the indicator for origin is not aligning up with the bounding box of my work. Is there a way to get this fixed?


Are you clicking the Frame button on the controller, or the one in LightBurn? The one on the controller is framing the content of the controller memory, and has no idea what is currently loaded in LightBurn. The frame button in LightBurn sends movement commands to the machine based on what’s loaded in LightBurn, not the machine. Is that difference in behavior what you’re seeing?

A post was split to a new topic: Framing the wrong size?

no i am trying to frame with the lightburn software itself.

When you’re in ‘Absolute Coordinates’ mode, the origin of the job is always the origin of the machine, so this is working exactly as it’s supposed to.

Read here about the different origin modes: https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

i see what you are saying about the indicator for origin. However when i frame from the lightburn software it does not frame properly. I click start and it doesnt even engrave where it just framed the job.

Can you be more specific? Where does it frame, compared to where you have it set?

hello, yes, sorry. I have attached a photo. sorry about the resolution it was a snip from snipping tool. I have the magenta set to no output. the black is what i am trying to engrave. It appears to have a X axis shift to the left when framing (marked in blue.) Only thing is when I press go it will engrave properly. just framing is messed up.

If I’m not mistaken framing takes all layers into account even if they’re not set to output.

Go to Edit > Device Settings. Do you have anything entered for a Laser Offset?

image

no, the box is unchecked.

No - if they’re not set to output they don’t get framed. I use that technique quite a bit to do multiple similar jobs … @travisr100

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.