Framing and Laser Offset

OK, I just finished setting up a new machine and for this one, I need to enter a X and a Y offset.

Problem is when time codes to Frame a job, it doesn,t consider the offset, which makes framing un-usable. I know from searching on the forum that this is expected behavior, but i’m looking for a workaround.

I’m running a K40 with C3d mini board. Perhaps there is something I could setup in the config file to copensate for the offset instead of setting that up in lightburn ??

Thanks for the help


Maybe another option would be to use a parallel red dot pointer on the lens holder mount. It may work out that you could offset the parallel laser pointer the same as the actual x / y offset you needed to set. But if not, LightBurn does have Red Dot Pointer Offset adjustment as well.

OR, you could just use the red dot pointer offset configuration without actually having a red dot pointer installed to manipulate the framing result to adjust for your offset :slight_smile:

Laser Offset

If your laser has a red-dot pointer that is not aligned with your beam, you can enable the Laser Offset value to compensate for this when framing and positioning.

Humm… not sure I understand what you are saying.

My home is 0/200 position

I can only engrave on my bed from 3/196, so my Laser Offset (Enable pointer offset as in your images) are set to X: 3.00mm Y: -4.00mm.

The drawings in lightburn can show my cut to start at 0/200 position on the drawing board. When it engraves it’s just the in right spot. But when I trace it, it really starts at 0/200 (which is outside my laser bed)… so I can’t use the tracing… trying to see if my explanation makes sense, perhaps I should make a video.

I am using line laser pointers attached to the head of the laser, they are aligned precisely to where the laser engraves. Are you suggesting I actually align them to be 3 and -4 mm off ? Not sure how I would pull that off precisely actually…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.