Framing with Laser without holding a key?

I recently converted my CNC setup to use a Fusion 5 Win 10 tablet to drive the CNC and laser. Lightburn works beautifully on it (of course!)…however, when I try to use the laser on Frame, I can’t seem to see the shift key on the virtual keyboard at the same time as the Frame button on Lightburn. I can’t seem to shrink either of them so that they can share the screen. So, two questions:

  1. Can I trigger the fire-frame combination in some way other than a keystroke-mouse combination?
  2. Does anyone know how to split the screen so that both the keyboard and Lightburn are displayed in windows that can be moved?

There was someone on here a few months back that was doing this with a tablet (maybe a unix tablet) and wanted to overcome the same issue. I’ll see if i can dig that up.


It looks like the software is inclined to (simulated) lift the (simulated) shift key when frame is selected. It looks like something that is dealt with in the keyboard software.

Thanks for that lead @JohnJohn I don’t know if it will help me on Win10…but I’ve reached out Doug from that thread and will see.

I have a mouse connected to the tablet through the USB, so I don’t have exactly the same issues…If I could see the Frame button, I might be able to click it while pressing the shift virtual key…but the keyboard covers the Frame button. Is there a way to move that dialog up?

I haven’t worked with the touchscreen devices at all.

I like corners, edges and buttons.

Is there a presentation port for HDMI video out that would give you a second monitor for the dialog you’d want to move up? Myself, if I were fighting with the layout and display I’d probably be reaching for some kind of physical keyboard - wireless USB?

Yeah…those are two options…I’ve thought about a second monitor…but the whole idea is to have a small attached footprint for my CNC and Laser setup…just a nice 10" flat panel really is clean and easy. I do have a USB mouse on it already - because I’m old school that way…but I’d rather not deal with the dust and a keyboard in my shop.

@adammhaile @LightBurn It seem that talking to developers of the virtual keyboard to get them to handle things differently is the main suggestion…couldn’t we just put “Double-click the Frame button to Frame with Fire”? I mean, wouldn’t that be super easy to do?

EDIT: I guess double click on a button isn’t really a “thing”…maybe a separate Frame with Fire button?

No, unfortunately I don’t think buttons handle double-click like that. I may just add a setting for this, or just make it the default if you have the fire button option enabled. I’m over here trying not to light everyone on fire, and everyone is complaining about it. :slight_smile:

Yeah…I edited that to mention that double click isn’t supported on buttons…I realized what I was asking for…

A setting would do it…or a toggle switch next to the frame button…or just about anything! :slight_smile:

No good deed goes unpunished…You know that already.

I’m just going to make it so that if you have the Fire button option enabled, it’ll frame with the beam on. We get a TON of “how do I frame with it…” emails, so it’s time to give in on this one.

1 Like

Works for me! Great. Thank you!

Honestly, it’d be fantastic if there was a switch to let us decide how this functionality works, or even just reverse the way it works so that holding down SHIFT will cause it to frame without the laser.

I regularly use neodymium magnets to hold my work down. I previously used ‘Frame’ partly to make sure none of my (reflective) magnets were in the path of the laser. For me, it’s less than ideal for the laser to always fire during framing.

I know, there’s always someone to complain about anything that gets changed.

Just my .02

Thanks for the awesome software and hard work you put in to it!

I can modify the code so it only frames with the laser on if the Fire button is on, not just enabled, but I was trying to save people a bit of hassle. No good deed goes unpunished, as they say. :slight_smile:

My preference for this would be that there would be toggle for laser operation during framing. Either in the Laser window similar to how Move, Size, Rotate, Shear toggles were added to the main window. Or as a sub-toggle to Enable Laser Fire Button in Device Settings.

What’s throwing people off with the change is that the laser is operating differently than before when they haven’t actively made a change themselves. The effect is magnified for those that had the Fire button enabled but didn’t use the laser light when framing.

With literally any change we make there will always be someone, somewhere who gets caught off guard, so we expect some of this.

The reason this was changed to be the new default behavior is that it’s extremely common for people to email and complain that they can’t frame with the laser on, and many have complained in the past that it should be the default and oh god why isn’t it, and LaserGRBL works like this, and on, and on… It gets tiring.

I can make it a setting, but people don’t read, so adding more settings & text is not going to help the email flood. If I make it an option, it’ll default to on so people who want to can disable the default behavior.

Hey, no worries. I get it that there’s no making all the people happy. My intention was constructive feedback, not to complain.

On the feedback theme, I would like to offer up that on my own little personal unimportant use case, I really liked the ‘hold shift to frame with laser’ functionality and would vote for that to be what happens if this toggle you mention is set to the ‘off’ position.

Thanks again!

I would strongly recommend one of your little toggle switches, located right next to the Frame button. You could default that toggle on if the Fire button is enabled…persist the setting between sessions. This way, people can choose to turn it off or on when they frame as they are looking at the frame button…it’s right next to it.

It’s been added to the device settings already. I can’t put it near the Frame button because that window is already space constrained, and every time we add something there (or one of the main panels) someone with a laptop yells at me that the windows don’t fit any more and why can’t we leave good enough alone. :slight_smile:

1 Like

Understood…and as a laptop user, even more understood! Personally, I’m thrilled you put it in and I will leave mine on :slight_smile: Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.