Frustrating bed coordinate issue

So, the workspace within Lightburn and my physical bed space seem to be in utter disagreement with each other. I have the workspace sized correctly in the settings, as well as the origin (I think)

i’m getting some really weird coordinates vs physical positions - the crosshair shows me where the head “thinks” it is, and i’ve marked with blue approximately where the head physically is:

When I “home” the laser, it believes it is at coordinates 0,7.8:

When I ask it to move to 12,0:

When I ask it to move to 12,12 (this crashes the head at the rear of the machine)

When I try to perform the camera calibration at 100% (i’ve outlined the travel path, it crashes the head all the way down to 50% scale) but it just seems like it ignores the entire bottom half of the bed…

I hope I’ve described this issue effectively. I’m running the latest version of Lightburn on Win7. Blue 50W chinese laser with C3D Laserboard.

Have you told GRBL how big the machine is, and calibrated the step sizes for the machine?

re: how big the machine is, is there some other value other than “working size” in Lightburn’s Device settings menu? If so, perhaps I haven’t.

step sizes - I don’t know anything about this.

The page size in LightBurn just tells it how big your machine is. You also have to tell the controller itself. If you’re using GRBL, that would be in Edit > Machine Settings, under X max travel and Y max travel values. If it’s still using Smoothieware, you’d have to edit the config file on the SD card for the new size.

If you just installed the board in your 50w, you likely have some other settings to adjust as well - the LaserBoard is a drop-in replacement for the K40, and comes pre-configured for that specific machine. If you have a different machine, with different motors, gearing, bed size, etc, you might need to make some other adjustments.

I’ve been using the setup for a few months now, and I had the lightburn camera in a “somewhat” working state for a little less than that, but i had issues with the overlay only covering a tiny portion of my screen and needing to make huge offset adjustments for accuracy. If I needed to adjust any more obscure settings, I wouldn’t even know where to start.

So I adjusted the X and Y sizes in the machine settings, and I got promising results (centered over the workspace) when I went to “frame” the tracking cuts, but when the job started, it didn’t actually engrave the “framed” area. It put the two bottom crosshairs roughly where the top should be, then slammed into the rear of the machine and tried to complete the middle and top two elements.

side note: is my machine engraving in the “correct” direction? it starts at the “bottom” of a graphic, and works its way up the image. (i.e, starts at the front and works its way to the back of the machine.)

Engraving front to back is the default, because most machines vent in the rear, and this keeps smoke from sticking to the parts that have just been freshly engraved.

If you don’t have the machine sizes or steps set up properly, the camera simply won’t work for you - it depends on being able to send the laser to “real” physical positions with accuracy. Get the machine set up and tuned properly first, then set up the camera and you should have much better luck.

There are a couple things that could contribute to the issues you’re having:

  • Machine size (sounds like you got this set up now)
  • Step size calibration (could also be an issue)

For step calibration, read here: How are steps calibrated?

I don’t think my steps are wrong, I’ve been able to make very precisely sized parts with lightburn for as long as I’ve had my machine. Even today, a 1.00" line results in a 1.00" line on a workpiece.

At this point, I don’t even know how to explain how stupid this problem is:

-Using the “set position” pointer is accurate and correct on lightburn workspace vs physical bed space. I can ask it to move to any coordinate through lightburn and the head will move to the correct space.

-Lightburn will “frame” a job in the correct place on the physical bed (and with the same dimensions. a 1.0000" cut gives me a 1.0000" result)

-Starting a cut that has been doublechecked with frame regardless of start position (eg, current position OR absolute coords) will cause it to engrave (i think) exactly 200mm towards the rear of the machine vs where it was set up in lightburn’s workspace, but in the correct X position.

So it seems to treat the workspace differently depending on whether it’s actually performing a cut or not.

Really appreciate you walking through this with me, really want to get this resolved.

Try this - in the console, type $# and hit enter, copy and paste the output here. Then type $$ and hit enter, and copy and paste that here too.

It also appears you’re using inch measurements. Can you try in mm, just to see if that’s contributing? I might’ve missed forcing the controller to inch mode somewhere.







I swapped units to mm in device settings, restarted lightburn & the laser, and still the same issues occurs

That’s very strange. There are no workspace offsets in your settings, and the measurements look correct.

In the Device Settings, do you have anything set for “Enable Pointer Offset”?

…well, i’m an idiot. I just had to remove the 200mm y offset that was inexplicably present. Thanks. Sorry for wasting your time.

You may have set that thinking it would solve your original sizing issue, perhaps? I’m glad it was an easy fix. :slight_smile: