Frustrating laser file malfunction

I would like some advice regarding a really irritating problem please:
I have been using a 100W Co2 laser with Ruida 6445 controller for about 3 years. I use LB software only to prepare the files for cutting. The problem is that about one in five files sent to the laser become corrupted with the laser deviating from the cut path like a toddler taking a crayon to a wall (it goes beserk), totally ruining the work. The biggest issue that the problem is not reproducible. If I rename and resend the exact same file, it may cut perfectly next time around.
Or the opposite may happen!
I have tried many things, including a factory reset on the laser, to no avail.
It seems like this is a software problem, the correct code somehow getting lost in translation between LB and the Ruida controller.
Any help or ideas will be much appreciated.

This sounds potentially like a communication issue. How are you connected to the laser?

I use a USB cable 'tween laptop and laser (and must admit I have not tried connecting via ethernet cable).

If the frequency is as often as 1/5 attempts, you could prove out the communication issue by transferring the RD file via USB drive. If that worked every time then that pretty much confirms the issue is in communication.

In that case a more robust USB cable may resolve the issue.

As you’ve alluded to Ethernet may be even more reliable. LightBurn Bridge may be the most robust yet.

1 Like

Thanks mate, you have given some good advice.

I have some ethernet cable that I can try, and am hoping it doesn’t come down to having to transfer via USB disk-but if need must that would still be less hassle than wasting a significant amount of material each time to get a job completed!

1 Like

I had numerous issues with USB, within a week of the Ruida arrival I had moved it to Ethernet…

You will still have failures now and then, but hopefully it will be caught…

I was directly connected, but that required an extra Ethernet port that you have to configure … not on the local LAN. The local LAN solution with/without the wireless bridge works the best.

I got a wireless bridge for about $12 US from Amazon and used it pretty heavily until the Lightburn PI Bridge software was released. That’s all I use now…

I had a couple of PI laying around… downloaded the software from Lightburn and used one of my PI to do this…

Good luck


Do you have any pictures of the results you are seeing?


Thanks for your reply, you are confirming that the problem may be a connection issue. I am encouraged to hear that my experience is not a unique one.
I have a ethernet cable and an appropriate port on my laptop, so will try that first. I have researched how to set up the ethernet connection, and it seems easy enough to do.
Thanks for mentioning the Lightburn wifi bridge, it is something worth looking into if plan A above fails. At AUD 188 it is somewhat expensive, but again I am spending $$$ on wasted material so the initial outlay may be cheaper in the long run.

Hi Billie, thanks for your reply

Attached is a pretty mild case of the affliction. You will notice that the laser played nice upto a point, then lost the plot completely

Note that you can build your own if you source your own Raspberry Pi.

I stated this, because it’s a lower cost option.

You can pick up a Raspberry PI very easily, compared to a few months ago when they went available for any kind of reasonable price…

Download the Raspberry PI image from Lightburn, write it to an sd card and it’s up…

Pretty simple and not what I’d call a real technical challenge.

I paid about $35 for my 3b, it’s gone up, but still rather resonable at Amazon.

My first was a PI 3b, but a thunderstorm drowned it… and I thought it was waterproof :tired_face: I’m now up on a PI 4, which are more expensive, but work fine. I had one I wasn’t using.

Good luck


Hi guys, thanks for your replies re. the raspberry pi option. I can get a 3B kit for around AU$ 130.

Take a look here:

There are Pi 4 4GB at AU $110 in stock. Not sure about shipping.

[EDIT] Realized that you probably are looking for the full kit so could raise the price a bit.

I’m running a PI 4 now… The only options you really need is an SD card, power supply and an Ethernet cable. I’d suggest a case, just to protect the PI.

You do need to be able to write to the SD card from your computer to install the software.


Thanks again for both of your replies, much appreciated.

Yes, if I choose the way of the Pi, I would probably go for the kit, which includes case, CPU fan, SD card, cable and 5V PSU. It seems like a nice little project that can be hidden inside the laser (found a handy “how to” clip on YouTube).

In the meantime, I would like to confirm the fault diagnosis this weekend by using the ethernet cable. If it solves the problem, then I guess "The Pi is the limit":stuck_out_tongue_winking_eye:

1 Like

The PI will perform better than just the Ethernet connection.

The PI has a software layer by Lightburn to assist with communications to the Ruida.

UDP has no error handling… doesn’t even know who sent it… just assumes what it gets is fine…

Good luck


Thanks Jack, duly noted!

Hi Marius, when I switch from my pi rotary back over to my flat software machine settings upload, my X coordinates are not engraving like they should. If I engrave a 1 in.² it will and gravy one by two rectangle. Any thing that I may be doing wrong? I thought maybe I should update my USB cable since that sometimes can be glitchy. But I thought maybe it’s not actually uploading every time I try and it’s remaining in the pie rotary machine settings.? My machine has been down for a week and I have jobs to do so this is getting a bit stressful lol I did post my initial issue here in Lightburn on a thread on its own and the only comment I got was to be wary of doing a factory reset for the X and Y in a Riuda beam cause I may loose all the settings.

This was my first machine and I love it when it works but unfortunately my recovery time can be slow because there is no technical help that comes right away. Any pointers would be helpful! :clap:t3::clap:t3::clap:t3:


When you change from the table to the Rotary, do you change anything?

How about going back to the table?


Are you loading the file and then starting from machine vs lightburn?

For example, on a Thunder Laser with a Ruida DSP, it’s highly recommended that you send the file and start from the Ruida.