G-code motion target exceeds machine travel on Genmitsu 3180 PROVER

I am new to Lightburn using a Genmitsu 3180 Prover. and running GRBL 1.1. When I load a file with a small graphic and attempt to run it, I get a “G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. (Right-click the ‘Devices’ button to reset the connection)” I get the same message if I use the laser pointing tool and probe anywhere on the workspace.

I have attached a screenshot and a copy of the current GRBL

GRBL 12_15.txt (345 Bytes)

What type of job start are you using?
Absolute coordenates?
IN the laser panel thats not in view

I’ll refer you to another topic that may be of value. The title doesn’t match but it’s likely still relevant.

I am using Absolute Coordinates. Not sure what you mean by type of job start. I am starting the job using the Start button on the laser tab.

I have read those thorougly and made sure the GRBL settings are as specified in the document. s for the third question, when I use the tool icon shown as " Set laser position by clicking on the page" my expected results would be that the laser moves to the specified position. Instead, I get no movement and in the console it shows the message referenced earlier.

The Job Origin is where in the work area is the 0, 0 point, relatively. It is right below the ‘Start From’ setting.

If the ‘Start From’ setting is ‘Absolute Coords’, the ‘Job Origin’ will be grayed out.

You should also read through the Coordinate and Job Origin documentation.

A screenshot of the laser window and the ‘Edit → Device settings’ window would be beneficial.


Can you list out here what you’ve so far to get it to this point? Specifically any configuration changes or setting changes.

Run $$ and $# in the console and paste here.

Some other questions to get going:

  1. Have you added limit switches to your machine? If so, where?
  2. Does your machine home? If so, where?
  3. About your first screenshot… where was the position of the laser head when you got the position you were showing in the upper right?

1.The machine does have have limit switches and they are enabled. I have both software and hardware limits option turned on in Lightscribe as well.
2 The machine homes to bottom left.
3. When the screenshot was taken, the laser was at home position, bottom left

The current gcode settings are:
















































Thanks for the help!

Thanks for the help! I have included the Machine and Lightburn settings as well in case they are needed.

It’s pretty clear you are not configured properly.

Screenshot from 2021-12-16 07-49-24

If this is a 3018, then it should be 300 x 180 bed size. Where did you get the 260 x 158 size?
If these are this far off, I wonder about the rest of them.

How big is the artwork? If you ‘select all’ in the edit window, it will show you the total size at the top.


1 Like

I think your problem might be this work offset, Not sure if its on purpuse but could imediatly cause an Alarm 2 as any motion will be forced to happen on negative work.

Not sure i can advise much further as i am not familiar with the machine but thats my best guess estimate

Can you do a “Get Position” immediately after homing and take a screenshot of the screen? Agree with @OrturTech that it’s something to do with the offset but the numbers aren’t adding up in my head.

He is set for ‘absolute coords’ so it should not show a negative number…?



The problem with the offset is, the machine does THINK it has to move though negative X and Y coordenates to arive to the start point. This on its own WILl trigger a Alarm 2
At least does on ortur, but again this machine might have the offset on purpuse as a tool offset, ence why i am being careful on giving instructions

When looking for specs on this machine it listed the “Effective Engraving Area” as 260 x 155 x 35mm so fairly close. Not sure if the Prover model is diff than non Prover models.
Genmitsu 3018-PROVer Semi Assembled CNC Router Kit – SainSmart.com

I see what you are suggesting, just not sure how to address it. The screenshot does show negative positions on home. As to Jack’s question on workspace size, I got that from a Robert Bland article re the Genmitsu Prover 3018 setup. I found it odd as well, but used it. Changing it back to 300 x 180 does not seem to affect my current issue.

Try this:

  1. First take a backup of your machine configuration
  2. in console issue $10=0
    This should have your machine report in workspace coordinates, not machine coordinates
  3. in console issue G10 L2 P1 X-260 Y-158
    This offsets the workspace to account for the negative coordinate system

Test and report back.

Glad you got the ‘size’ numbers from somewhere reasonable. I didn’t think it change this issue, it just makes me suspicious that there are other setup issues. That was my only thought.

I have never seen acceleration values as small as on that machine. Mine are about 600mm/s^2, if I recall. So much of this is configuration. And that’s where we will more than likely end up…

Can you screenshot the whole console on reboot, like this…?

Notice the line between the 'OK’s? The ‘MPos’ is the machine position.


Have you sent it “G0 X0 Y0” telling it to go to 0, 0?

Might see if it likes that after it has done a reset.

Have you tried the ‘clear origin’ and ‘set origin’ options?

Have you tried to ‘move’ goofy to the lower left, near home, and start the engraving from there?

Can manually move the head via lightburn ‘move’ tab?

Might let us know what happens to the X coordinates, increase or decrease when you move it right or left? Same with Y, increase or decrease forward and back. I’m just trying to verify that it’s operating in the proper quadrant.

Just ordered this to fool around with. It’ll be number 3… All of mine power up and read 0, 0, 0 when you click on ‘get position’.

Good luck


That seemed to resolve it. After entering the command it showed x as 1.5 and y as 1.5 which is the same as the offset I have for the limit switches. Bad news however, is immediately after seeing this I went to my machine settings to check this and and get a communication with controller failed message. I notice as well that in the laser tab, it shows Busy with a 100% value. Wondering if I don’t have another issue, possibly with the controller board? At this point, the system is totally unresponsive.

That’s very odd timing. Was this accompanied with any dramatics? Sparks or smoke or anything?

It may come to that but I don’t think anything we saw earlier would have indicated that you were actively having a problem with this.

Try shutting down the machine and your computer. Unplug the machine from mains power. Try starting back up and see if anything changes. Try another USB port on your computer if you have one. Any change in behavior?