Galvo door interlock IO setting

I imported my galvo settings from the ezcad2 markcfg7 file with success, and the laser works (Raycus 30W q-switched). One setting that did not get successfully imported yet was DOORINPORT=15. I have a diy door interlock switch wired to input 15, and I would like to configure Lightburn to respect that interlock and not fire the laser unless input 15 is green. Searching device settings, I cannot find anywhere to enable this. I can see the red and green indicator working correctly in device settings.

In a youtube video, I saw that Lightburn 0.9.24 had “enable door open protect” as an option under machine settings, but I can’t find such a menu in the new lightburn.

Hey @REACH_LAB

I can confirm that this feature is coming for Galvo, and that it is in internal testing but I cannot give a time line as of yet.

The feature you saw is in our DSP/Gcode protocol but needed an entirely new implementation for Galvo and will likely be in the 1.3 release.

1 Like

I’m looking to migrate away from EzCad2 on our fiber laser, and was impressed by LightBurn (running the trial)… unfortunately since the laser is used in a shared lab space, the lack of interlock switch support is a deal breaker (we specifically bought the enclosed model with the interlock on the door so management would support the purchase).

Anyway, I just dropped in to post that @REACH_LAB isn’t alone in looking for this feature. I’m glad to hear a solution is in progress, but do you have any idea of timeline for the 1.3 release?

Sorry we don’t have a time line for 1.3 other than “Soon”. I understand the desire for this. We have a few other features in development waiting for 1.3 so it will be a while still.

Just come to enable this important safety feature myself. Glad to hear it’s in the pipeline for 1.3. Thanks for looking to include it “soon” :slight_smile: