Galvo Rotary Axis Split size aliasing / misaligned

Hi there

When I attempt to run engravings using my OMTech 30W laser w/ a Cloudray Rotary, along every “split” there is a noticeable misalignment.

I’ve ensured that my workpiece is square to the laser head, but that didn’t change the issue. Basically, along any “split” in the job, there is a large misalignment. I’ve tried various splits (5mm, 10mm, etc) and they all have the same issue if any splits are used - with a 10mm split the misalignment occurs at 10mm intervals, and so on.

The issue:

Rotary settings:

Marking menu:

Device settings:

Layer settings:

I’m using Lightburn 1.5.02 with a JCZFiber device

Take a look at my reply about 3 down in this thread. I think your split is too large, I would be less then 1mm for that sized cup. If you dial your settings in you can loose the overlap as well.

One other thing, may be nothing, but I have gotten same results when I had rotary set for 6400 on the microstep drivers DIP’s, LB set for 5000, and then stretched the Y scale of the image to make it the right size on the cup. Just throwing that out there.

1 Like

Thanks for the tips… I was able to get an acceptable result at 0.02mm split size (the smallest allowed) - however it takes forever.

This is at 1mm:

This is at 0.1mm - it still has the issue, and is the lowest reasonable speed it seems (otherwise it takes over 2 minutes to do - perhaps partially due to the acceleration wait time?)

This is at 0.02mm (the incomplete one with just evi):

You have something else going on.
I would suggest creatiing a 20mmx20mm square, burn and measure
I think your steps are off

I’d suggest the split size be a multiple of your interval

The takes forever problem is that Lightburn must send code to the controller to move the rotary, then wait, send the scan code and so on… It’s much faster to use a larger split size.

How far you can rotate it (split size) is related to the focal length and the size of the diameter.


1 Like

The sawtooth isn’t a speed problem, it’s a step problem. Either steps per 360 is off or diameter is wrong or both.
But yes, tiny splits are slow. Fat steps distort. 3 bears kind of thing.

If he’s scanning along the mug from top to bottom for the X axes… The steps for the X axes appear to shift not the rotational movement…

Looks like the correct Y position, but not the X direction…


I asked Cloudray (the seller for my rotary axis) and they said 6400 or 12800 both are correct. I confirmed on my controller and its set to 12800. I marked the rotary base and the chuck with a line and it returns to the same spot. It also appears to be a direct drive stepper unit so I don’t think belt slack or anything would be causing it.

@jkwilborn I also tried swapping axis and had the same issue unfortunately… I’ll try the interval/split size method - and test some more straight lines

I was originally scanning along the Y axis (mug rotating on Y axis) - I tried changing to X axis for this test and seem to have the same result.

I’d suggest the split size be a multiple of your interval

Does this apply when using a vector file? I don’t see a way to set interval on a vector. I’m guessing it doesn’t because its scanning theoretically a 1:1 copy of it instead of turning it into an LPI equation.

@Albroswift - I tried this with a 5x10 and a 10x20 and the results seem to be bang on when measured with a caliper. The mug is 81.04mm in diameter, and I had 84mm - however trying 81.04 seems to make no difference :frowning:

So try this:
Diameter 81.04 circumference=254.594 steps= 12800 so for each step surface moves 0.02 (0.0198) can’t move half that, can’t move 1-1/2 times that, SO…
Try split size as a multiple of 0.02 (0.0198), like 0.02, 0.40, 1.98, and line intervals of 0.02, 0.01, 0.04, like that.
If you have overlap make it equal to or a multiple of 0.02 if not zero.


I see! This makes a lot of sense now.

I set my overlap to 0.04 and my split size to 0.8mm and its working so much better now!!

So the math is:
object circumference / steps = split size interval

great to know :smiley:

1 Like

I call it resolution, glad I could help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.