Gantry will not move engraving text

O.K. I have solved my problem… My machine is now working properly… I have turned the rotary on and off numerous times in the rotary setup. nothing there. While searching in the Settings section I found a small box that said show rotary on the
main menu. After turning that on a mall box shower up on the Laser section on the main page. After this my gantry is working correctly… Thanks many times for your.
help. Your responses kept me searching… Otherwise I might have given up…Kenny

1 Like

Glad you sorted it out. I’m curious, though, because the gcode looks fine. :person_shrugging:

That one small box in Settings that said" Show Rotary Enabled On Main Menu" was the trick to it working. Main settings not rotary setup. After turning that on things started working again. I don’t know why but this a computer world and a small click makes a huge difference. I figured I had missed something so I kept searching. With your encouragement I kept going. I now know how to take a screen shot and attach to something… I also figured out how to copy the grbl file and attach. I have expanded my computer knowledge also. All is well now. Thank Again Kenny

1 Like

This is last post about Lightburn. As of this morning it WILL NOT work again… I give up.
Will go to another program…Thanks Kenny

Get it working on the rotary. Then disable everything for it in lightburn before disconnecting the rotary, turn off everything, take away the rotary reconnect the Y and restart everything. Its worth a try i had an industrial machine ones with a similar problem if the rotary pipe profiler was disconnected in the wrong sequence. Jim…

Don’t give up, I have had CAD/CAM programs over the year that cost thousands, and a lot of them wouldn’t even come close to lightburn. In my opinion there’s not much out there to match it. I have spent a good part of my 64 years around cnc machinery of one type or another. Believe me I had my fair share of heartaches with them. My atomstack x7 and lightburn work well together.

I concur. At this time, your alternatives aren’t great for software.

Additionally, from what I’ve seen it seems this may not even be an issue with LightBurn. This may be an issue with D1 firmware or possibly a hardware issue. D1 rotary uses Z commands to drive the rotary. This is what happens when the rotary is enabled. The gcode generated in your test does not have any references to Z-axis, only X and Y. So the commands to the laser seem correct. Somehow the laser is not responding in kind.

@jimcoy makes a good suggestion about rotary shutdown procedure that’s worth trying. The D1 might be getting stuck internally in rotary mode.

The other thing I would suggest is to check the connectors for the Y motors and make sure they’re properly secured to the controller. Perhaps they’re not making a good connection.

O.K Gentlemen… You win. Went with Jim and tried his idea. It actually is working tonight
Might have been the issue all along. Working for now. Great to have ya’ll behind me and the little push to keep going. I was very much discouraged all week. Had to shut the custom wood working down due to extremely high hardwood prices. No one would pay material and labor prices.
Want the engraving to keep me off the streets and out of trouble. Thanks for the push and encouragement. Your help has saved me from tossing Lightburn to the street.

1 Like

Good to hear, and you’re welcome. Here’s hoping it stays working.

Glad to hear that your problem has been resolved!
In my opinion, if your issue not happened after the firmware update, then it is not the firmware issue of D1. Also, if you can resolve the issue by change settings, it cannot be the hardware issue. Sometimes the settings changed on Lightburn will cause such a problem. Anyway, the most important thing is that you resolved the issue by yourself, really great!