Getting lines across when burning, and lettering looks like crap!

How can I make my lettering look better?

And why I’m I getting these lines across when burning, and how can I stop them?

What kind of controller are you using? (I assume GRBL, but which version?)

If it’s 1.1f or higher, you need to set $32=1 (laser mode). If it’s earlier than that, you need to use the GRBL-M3 device in LightBurn, so it explicitly turns off the beam with every G0 move (laser mode normally manages that).

Regarding the sawtooth edges, you have likely got a slightly loose belt on the X axis.

It’s a Jtech 7W laser.

Where do I find the controller info?

It says GRBL when I find the laser.

When you first connect to LightBurn, it should say GRBL 1.xxx (press $ for help) or something like that.

Copy that connection message here.

It just shows GRBL, something about use for 1.1f or higher, using variable power mode?

Not sure if that’s what you are talking about?

As in, please copy the exact text of the message that appears in your console so I can read what it says, not just the bits you remember. :slight_smile:

Do you mean in the find my laser box?

In the console window, when your laser connects:

image

ok

Waiting for connection…

Waiting for connection…

Grbl 1.1g [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

ok

[MSG:Caution: Unlocked]

ok

[VER:1.1g.20170629-Inventables:]

[OPT:VMP+,15,128]

Target buffer size found

ok

$0=10

$1=255

$2=0

$3=3

$4=0

$5=0

$6=0

$10=115

$11=0.020

$12=0.002

$13=0

$20=0

$21=0

$22=1

$23=3

$24=25.000

$25=750.000

$26=250

$27=1.000

$30=1

$31=0

$32=0

$100=40.000

$101=40.000

$102=188.976

$110=8000.000

$111=8000.000

$112=500.000

$120=500.000

$121=500.000

$122=50.000

$130=750.000

$131=750.000

$132=100.000

ok

Waiting for connection…

Waiting for connection…

Grbl 1.1g [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

ok

[MSG:Caution: Unlocked]

ok

[VER:1.1g.20170629-Inventables:]

[OPT:VMP+,15,128]

Target buffer size found

ok

<Idle|MPos:0.000,0.000,0.000|Bf:15,127|FS:0,0|Pn:P|WCO:-649.950,-655.025,-59.452>

ok

Grbl 1.1g [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

ok

[MSG:Caution: Unlocked]

ok

[VER:1.1g.20170629-Inventables:]

[OPT:VMP+,15,128]

Target buffer size found

ok

You need two macros - one for “Use Laser” and one for “Use CNC”. Their contents will be:

Use Laser:

$10=0
$30=1000
$32=1
G10 L2 P1 X-750 Y-750

Use CNC:

$10=115
$30=1
$32=0
G10 L2 P1 X0 Y0

Prior to using the laser, click the ‘Use Laser’ macro button, and when you’re done and want to switch back to using the CNC, click the ‘Use CNC’ macro button. To define a macro, go to the console and right-click one of the buttons. Copy the code I wrote above and name the button accordingly.

The ‘Use Laser’ macro sets the machine to report positions relative to the user workspace, sets the spindle max RPM parameter to 1000 (the GRBL default), enables laser mode, and zeros the machine origin to the front-left. The ‘Use CNC’ macro sets everything back to where it was before that.

Thank You!

I opened the Macron button and entered the code you provided.

Should it look like this?

I will test it in a minute.

MACROS

The button labels are correct, but they could be named anything. :wink: The important part is what you put in the macro contained “under” that button.

I put:

Use Laser:

$10=0

$30=1000

$32=1

G10 L2 P1 X-750 Y-750

Use CNC:

$10=115

$30=1

$32=0

G10 L2 P1 X0 Y0

Is there a way to limit the travel to a certain area on the x-carve board. I have a board setup on top of the x-carve board (as my work area).

I’m limited in space, so setting the machine to 0 cause it to run into the side wall, or the back right. I can’t push it all the way back to the back edge because (built in table is right against the wall) so I think it’s messing with zoning the machine.

Can I zone it for a smaller area, even though I have the 1000 x 1000 X-carve?.

I plan on moving the x-carve to my garage this summer, but right now it’s in a small bedroom, so I’m limited on space.

The homing switches are in the rear-right, are they not? So unless you can home the machine, it has no idea where it is. You could “manually zero” it by powering it up with the head at the front-left, and if you don’t home, the controller will treat that as the zero point, so then you’d only need the $32 and $30 settings in your macro, not the other two lines.

Yea, That’s the problem I having.

I will see what I can do to my setup to make it better.

Maybe I will add a fold down shelf to to the front to extend the table out, then I can lower it when it’s not needed.

Thanks for all your help so far.