Grayscale Settings

Hello! My name is Cristian, and I’m new into the forums. I’ve built a machine with a 2.5W laser diode. I’m very intrested into grayscale photos, that’s why I have been testing with LightBurn and i’ve get good results for a first impression. There are some photos. Today I ran a grayscale test but i dont think this is a good result, does anybody have an idea? thanks in advice!
edit: i could only post one photo so here’s the grayscale test photo


It looks like your machine does not do power ramping, which is supported by GRBL 1.1f, and SmoothieWare, but not older versions of GRBL or Marlin.

To compensate for this, enable overscan, and set the amount appropriately, and you should be able to get rid of the black edges on the sides of the cuts.

Hello, thanks for your reply. I had $32 = 0; I dont know why sometimes it switches to 0 when I use another program. Now that i have it $32 = 1, with the laser mode enabled, it works, i have made the grayscale photo and also other things. but the thing that now i can’t do is to engrave images…the laser turns on but in low power I think, but it is on 100% power, any tip? 3 days ago i made the eye with LB with no problem :frowning:!

Other apps might change things over to the settings they want to use. LightBurn doesn’t alter your settings, but I’m beginning to think I might have to.

Every time you run LightBurn, you should have a macro button set up to do:
$30=255 (or 1000, which is the GRBL default)

The $30 setting needs to match the “S Value Max” setting in the Device Settings in LightBurn, shown here. 255 or 1000 are both fine, as long as both of the settings match. One is in the controller itself, and the other is what LightBurn is told to use.


1 Like

thanks for your reply.
as I said, I can engrave text or whatever I “create” with LB; but when I import an image and burn it doesnt burn. i’ve tried different images and nothing :frowning:
(edit: by burn I mean engrave, the laser do get on)

Post the settings of your controller (IE, what the console says when you type $$ and hit enter) and post a screen shot of the settings you used when trying to engrave an image.

suere he it goes

With a 2.5w diode, 6000mm/min might be too fast. I’d try 4000 to start with, and lower the Min Power value even more, down to about 2%, and make sure the “S Value Max” setting in the Device Settings in LightBurn is set to 255, because that’s what your laser it set to.

Hello, thanks for your help, but I still have no results with image engraving =(. what could be the factor that is giving me this issue? does any other forms user have had this problem?

I truly have no idea. If it cuts, it should also engrave, as the commands used are identical - the same GCode instructions are used, so it makes no sense whatsoever that you get “no results” when engraving. Can you try using dither instead of grayscale?

It didnt work. I’ve tried uninstalling and installing again but also didn’t work :frowning: thanks for your help tho

I just noticed in your machine settings that your maximum speed is set to 2000mm/min, and you’re trying to engrave an image at 6000mm/min. That likely means it’s going to reduce the power to 1/3 because it can’t move that fast. Try increasing the max travel rate ($110, $111) or reducing the engraving speed even more.

Hello, again thanks for your reply and help. i’ve checked that out and now the machine travel faster xD, it does cuts and texts good, but still can not engrave images :confused: :confused: :sob:

This makes no sense - the same commands are used for image engraving as cutting, so if you’re able to cut, you should also be able to engrave an image.

On the bottom of the cut settings window, click the “reset to default” button, then change just the speed and power values, but nothing else, and see what happens.

This has never happened before - If the machine cuts, it’s responding to GCode commands, so it should also engrave, but you’re not giving me any details about what it’s actually doing, so I don’t know how to help you. You haven’t said which version of GRBL you’re using (or even that you were using GRBL - I guessed). More details will help.

Ok you are right. Im using GRBL 1.1g. Im using a laser diode 2.5w, a cncshield v3, a4988 drivers and nema 17 motors. what is curious is that I could engrave photos before.Tried the reset to default but nothing happens.

Has anything changed in your GRBL settings since the screen shot you took before? Can you also say which value you have set in Edit -> Device Settings -> S-Value Max?

Shown here, lower right:
Mine is 1000, but for your GRBL settings (at least, the way they were) it should be 255. If you post your current settings, it’s possible something changed that again.

nothing has changed, those values didnt match but then i changed it to 1000 on the grbl config too, and now is at 1000 at the 2 spots and the values match

That’s very likely the issue. They have to match.

the values DO match but i cant engrave images