GRBL Diode rotary slanted when fill engraving

Hey everyone, I’ve been having trouble with my rotary. At first it was an absolute mess and I got it to a much better spot with some help from another group but this part seems to have them stumped. I’m hoping someone here can help

I engraved two 20mm squares on the same cup, one using “line” and the square is perfect

One using “fill” and got a skewed square… making a parallelogram

Anything I engrave with line is appropriately sized and straight, but anything engraved set to “fill” is horrible skewed

I am using:
Mecpow x3 pro 10w diode
Mecpow roller style rotary
Lightburn for Mac

Any help is greatly appreciated, thank you in advance

Hi Erin

Try this please.
Coat the cup with painters tape (something the laser can easy mark at low power)

Run the same fill square at 20-30% power?
Does it slant the same.

Suspect you might be having some power delivery issues. What power output is the power adapter?

double check the accuracy of your rotary device in terms of steps/deg. I’m just guessing that if the accuracy is off by even 0.1mm/deg, then a skewed effect like that can occur in a raster scan pattern ?

If the steps/rotation or it’s equivalent is not correct the Y (rotational) axes will stretch or compress the graphic, not skew it.

This looks a lot like what happens with a roller rotary when it slips each step.

A copy of the .lbrn2 file and how the rotary is configured. Normally these are using the Y axes but @Martiner418 needs to let us know about their machine.

The other art looks like a vector job and I don’t see slipping, so it helps if we know if it’s a wheel/roller or chuck rotary and have the file, along with how you have it setup… This looks too perfect for a slip.


If you mean the rotary test, I have a perfect result. I’ve checked and rechecked what seems like a million times


The output is 12v 500mA

And I’m engraving at a lower power right now, I will post the result

It’s still slanting

Did you slow down the acceleration, speed or both?

It looks like the Y is slipping a bit each move and this is usually caused by the acceleration values being too high.


I did lower the engrave speed… I’m not sure I know how to lower acceleration?

I hope you saved the original settings of your controller?

These are from my screw driven cnc, so don’t use my values.

If you set this to some small value … a good starting place is 1/2 of the current value and keep going… For some of my roller work, mine is set to 10mm/s^2… Keep in mind it now takes longer to get to speed, but the acceleration won’t try to spin the mug too quickly.

If you cut it in half and the image doesn’t change we’ll have to try other things.


I never even realized I could extend the menu to change that, so I’m sure my settings are whatever the default is for my controller, and actually as I’m clicking around it doesn’t even let me change it

If you click on the field, you should be able to change it… that’s what the gui is for.

Move down and use save to file to back it up… save it twice as factory settings, once locally and once somewhere you can archive it.

It’s much easier than figuring it out with no information.


I took it from 500 down to 200 and it looks exactly the same

I’d expect more of a jagged look it it were slipping as I was hoping.

This is occurring on the X axes, is this correct? I mean the Y distance is correct, it’s just shifted?


Correct. Someone advised me to delete settings in lightburn and it will get rid of everything I’ve changed and I’ll have to connect my laser again but all of the values should apparently be reset. I was afraid at first but in doing some more research. What are your thoughts here?

Lightburn doesn’t use acceleration values except when a preview is done, then it tries to emulate what kinds of speeds it can run and how fast (acceleration) they can go in a fixed distance.

These are stored in your controller. Software doesn’t need to know these kinds of details.

Some controllers will not allow you change some of these values, some will, but will be reset via a power cycle or reset.

If you set any of these, you set them in the controller.

Before changing any of these, the Machine settings has the ability to save or make backups of your settings… so you should have save to file first. That way you can load from file and write it back to the controller.

If you slow things down or speed them up for specific uses, then save that configuration with a meaningful name… Later when you need those settings you can load the file and write it to the controller.

Make sense?


I’m pretty sure I have done evething you’ve said and I’m still having the same problem. So I did just reset everything and am starting fresh. If I can’t figure out by the end of the week why the heck this is happening ,the thing is going back where it came from until I can afford a better option. I’m so annoyed with it, I typically pick up on these hobby type machines pretty quickly but this has me feeling defeated. Thank you so much for all of your help

If this is related to the X axes, we may have been chasing our tail.

Do you have an original controller setting file, that came with it? You would have had to go into the machine setup or copy/paste out of the console to have this… they exist within the controller.

Any why to compare the X axes settings now with the original from the factory…

Do you have a time frame to return this? I’d open up communications with the vendor…

Is this making this rectangle correctly on the regular table? I’d suggest you lase a scrap of this with no rotary engaged.


Yes, the issue is only occurring when using the rotary. I think for the laser itself we’re past our time to send back, but the rotary is still within the time frame

I’m downloading my lasers drivers now. It was working without doing that, so I didn’t bother when I was engraving flat things, but now it’s looking like it’s going to be very important

What drivers? It should work with it’s current drivers…?