Grinding in Z Axis

You can publish externally and link here.

  1. check that the x-axis motor is not plugged in reversed on either motor side or controller side
  2. is it possible that you’ve mounted the gantry upside down?

Is it backward?

That looks correct as far as I can tell.

I get an error when trying to go through that link. I also don’t have facebook so won’t be able to view if a facebook account is required.

Did you check the cabling for the X-axis motor?

I did. Everything looks tight.

To be clear, I’m not asking if it’s tight. I’m asking is it possible that the cable has been plugged in reverse?

Also, does the machine attempt to home on power-on? Or only when connected from LightBurn?

They’re all in the right way. The cables have different ends so there’s only one way to plug them in. The one cable that has the same ends I switched and it didn’t work.

It does go home to the back right when I power it on. It’s not just LightBurn.

Could it be something with coordinates messed up somewhere?

It also burns off-center.

It sounds like you’re describing which end of the cable goes into which port. Have you checked if the connector itself could be plugged in rotated 180 degrees.

No. This is entirely hardware.

How did you get to that point?

Does the burn match what was in LightBurn or has it been mirrored?

I used XCS to do this. I didn’t try LightBurn yet. And yes it was mirrored. I will double check all the connections.

This likely confirms it. Somehow the motor is working in reverse. The most probable cause is that the cabling has been plugged in incorrectly. It could also be the result of the cables being improperly made. I’m not super familiar with the mechanics of that machine but there’s a slim chance of gearing or belt routing causing this.

I checked the cables. They’re in right. So it’s likely something bad in the cables. Thank you for your help. I really appreciate it.

Are the wires that go into the X-axis stepper motor terminated at a connector? Or do they come directly out of the motor? Can it be unplugged at the motor? I assume it’s a 4-wire cable.

Does that cable plug into the controller end directly or does the cable merge with a larger connector before being plugged in?

I thought showing you would be the best way to answer your questions to make sure I get it right.

A couple of notes:

  1. I actually can’t see how the cable routes to the controller. It seems like it converges to the large white cable. If so, might not be able to easily change that on the controller side. Can you confirm this is the case?
  2. It looks like the cable could be unplugged from the motor. If so, can you try plugging it in upside down?
  3. On a side note, I didn’t realize the machine had limit sensors on both sides of the gantry.

Okay, I feel like a dummy but is the controller the laser itself or is it the motor?

The controller is the PCB/logic board that’s mounted near the front of the machine into which the USB cable and other cables connect.

  1. It does converge to the large cable.
  2. I tried to plug it in upside down but it doesn’t fit that way.

At this point I think you have 2 options:

  1. get in touch with xTool to explain the situation and see if they can resolve it
  2. attempt to modify the cable. This probably won’t be that hard but it can be intimidating. However, I won’t have time until later today to help with this, however.

Which way would you like to proceed?

I really appreciate your time. I tried calling xtool yesterday. They escalated my ticket but I haven’t heard back from them. I can just wait for them.