Hard limit triggered - TwoTrees TTS-20


I’ve just been setting up a TwoTrees TTS-20 Pro and followed the ‘first project’ Lightburn tutorial. Everything seemed to be going well until hitting start! At that point I started to get

Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.

On or near line 65:

Job halted


Reading through these forums this seems to be related to the laser hitting my X Axis stop. I’ve checked that I am using Absolute Coordinates and I’m really not sure what the problem is. I tried removing power from the X Axis stop switch but the laser head just moved left and right and didn’t output any laser beam (I’m hoping that’s because the stop switch was unplugged, but I’m not entirely convinced…).

Please see below a couple of screenshots of my settings, and here is a YouTube video showing what happens. Any help very much appreciated!

What happens when you go from frame to start without homing?

Thanks @Dskall - if I do that it just slams itself back to home and triggers the switch.

Do your jog controls work and move in the right directions?

Yes they do. I’ve actually just had a breakthrough - it was overscan set to true on one of the layers. With this enabled it kept triggering the switch! Turning it off has solved that issue. Now I just need to work out why the laser isn’t firing!

I’ve tried $30 and set S value max to the same value, but there is no output. Do you know of other steps I could try?

Laser not firing framing or not firing at all?
Do you have $32=1
Enable laser fire button in device settings and see if it fires when you click fire button.

I’ve had to stop tinkering for a while and make some dinner for the family so not sure on the dollar value, but I enabled the fire button, and set laser to fire on frame.

This (and the full run) outputs a blue dot, but it makes no impact on the ply board. I’ve tried differences focus depths but no difference. My layers are set to output, and for the time being the power is set to 100 with a reasonably slow speed. I guess I’m missing some power override setting somewhere perhaps?

Can you screenshot whole area with cuts/layers and go to console and input $$ and paste results.

Sure - here are screenshots of the panel and then some more detail for each layer.

The output of $$ is below:






























































many thanks for taking time to help with this!

360,000 mm/min?
May want to slow that down a lot.
3600 maybe?

Yeah I just noticed that too! I think that is a recent typo from playing with settings trying to get the laser to work.

It’s a bit late here now, but I’ll double check in the morning!

I was having something similar and I unchecked the out of bounds warning in the device setting and didn’t have the problem again. I’m new to all this so I don’t know if this will help or not.

1 Like

OK, I’ve gone in and corrected the speed typo and checked the ‘out of bounds’ warning setting (which was already disabled), but still nothing. I’ve raised a case with TwoTrees two in case there is actually an issue with the laser - although I suspect the issue is with me!

Have you figured it out?
I got exactly the same issue and can’t solve it .
Running TTS-20 PRO with lightburn.

Please help me if you already figured it out. I’m stuck. Thank you

Exactly same issue.
I tried everything. All every and any setup- nothing works.
I start assuming that maybe just maybe optics in laser got loose or shifted while assembling or transport. I’m ready to start taking laser apart.

Help me before I go crazy :joy:

Homing issue?

Yeah, for me it was the over scan settings

Did you get it to home properly? Looking again at settings I would change $27= to 3 and $24= to 100

No I got homing fixed. Everything working laser running but NO CUT NO ENGRAVING. LIKE THERE’S NOT ENOUGH JUICE