Hard limit triggered

Hi all, I’m fairly new to lightburn and laser engraving machines I’m general, so forgive me if this question may sound a bit obvious.

I’m having issues with my machine. I have an Atomstack P7 M40. Any movement except for homing results in the error message of hard limit triggered. I also notice a significant difference in the sounds made when the rehoming function is used vs for example setting the laser position.

This is becoming really annoying as I have only been able to use the machine once without this problem.

The attached photo is the error message that appears when I try to frame my project.

Any help would be appreciated :pray:t2: Thank you in advance

I think the photo never get attached.

What was the coordinate system in Start From: set to in the Laser Window? If not already, switch to Absolute Coords and see if this makes a difference. Absolute Coords is the most intuitive mode where your workspace matches your laser area.

Sorry I forgot to upload the image. Here is the error message. I tried working with absolute coords, I’ve had better luck with it but I still have to re home it about 20 times for it to work

Are you saying you get the same error when working with Absolute Coords? Or something else?

Can you explain what you are doing when you get this message? Are you trying to use the jog controls and going beyond the working area of the laser?

Please send a screenshot of Edit->Device Settings.

You can get a cleaner screenshot if you use the “PrtSc” button on your keyboard or run the Snipping Tool application from Windows.

Yes, the same errorr appears when i use absolute co-ords, This happens when I am trying to frame my project.

One thing I’m noticing is that it appears your device type is incorrect. You are using GRBL-M3 when you should be using GRBL. I don’t think this would cause the issue but you should correct this.

Are you able to use the jog buttons in Move window to move the laser head at all?

Also try one thing:

  1. Enable the “Show all” switch in Console Window
  2. Run framing operation that normally fails
  3. Turn off Show all
  4. Copy and paste all output content from that window in a reply

Thank you! I’ll give this a go and let you know how it works

I did use the jog buttons to move the laser head and I did notice, it moves a different direction than the button I press. Below is the output from the window



Starting stream

G00 G17 G40 G21 G54
















































Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.

On or near line 40:

Job halted

Stream completed in 0:03

[MSG:Reset to continue]


Grbl 1.12930h [’$’ for help]

[MSG:’$H’|’$X’ to unlock]


[MSG:Caution: Unlocked]






Starting stream


Hard limit triggered. Machine position is likely lost due to sudden and immediate halt. Re-homing is highly recommended.

On or near line 49:

Job halted

Stream completed in 0:03

In which way do the jog controls not work as expected?

Also, can you send a photo of how the machine is oriented right after doing a homing cycle?

For example, the button used to move to the right moves down instead. Also now any movement or framing results in this hard limit trigger error.

I have my machine facing me. See attached

Thanks for the picture.

The reason why your jog controls aren’t working as expected is because I believe the “expected” orientation of that laser is 90 degrees counter clockwise. So that you’d be reading Atomstack right side up.

Also, did you change the device type from GRBL-M3 to GRBL yet? Make sure to do this. You’ll probably need to recreate the device to be able to do this.

Can you confirm that the resting position in the photo is right after a homing cycle?

If so, can you run through these tests?

  1. after homing, push “Get position” in the Move window. Make note of the position.
  2. use the jogging controls keeping in mind the expected orientation and move to top left, then do “Get Position” again.
  3. repeat this for upper right
  4. repeat this for lower right.

I want to make sure that the reported boundaries of the laser are the expected boundaries.

Hi yes, I have changed the device type to GRBL and have now turned the machine counter clockwise. That picture is the homing position

Homing position- X=0 Y=0
Top Left- X=210 Y=0
Top Right X=210 Y=210
Bottom right X=0 Y=210

These look fine to me.

Can you reconfirm these? I’m hoping you have the values swapped. Otherwise not sure what’s going on.

Also, do all jog controls now work as expected?

If so, can you try an operation? Are you still getting your hard limit error?

Hi the jog buttons now work as expected, as far as moving in the correct direction. However I noticed a problem with the X axis. Moving the X axis forward with the jog buttons doesn’t seem to work on the first two attempts. However, light burn still picks up the coordinates as if it has moved forward. This results in the coordinates being X=315 Y=0 in the top left and X=315 Y=210 in the top right. for the bottom right the coordinates are X=0 Y=210. This is all assuming the homing position is the bottom left.

I’m trying to get my head around those coordinates. Typically the coordinates for anything on the left side of the machine should have X coordinate of 0. And again, anything along the bottom would have Y coordinate of 0.

Is it possible that you the cables going to the stepper motors were plugged into the opposite port on the controller? Can you double check this?

It could also be that the orientation you had earlier was correct and that this is meant to be an upper-left origin machine.

Anyway, not super important right now since the jog controls are working as expected. Let’s see if it will burn in the correct orientation first.

This means you’re missing steps. Likely causes include

  1. Belts are loose. Recheck all belts. Make sure there is no visible slack. The belts should be taught without being stretched.
  2. Check that the pulleys on the stepper shafts are secure… make sure the grub screws are secured at the flat portion of the stepper shaft
  3. This can also be caused by attempting to move too quickly and the motor can’t keep up. Fast speeds can also expose issues in the other 2 causes.

Can you review the mechanics and then power cycle and run tests again?

The X axis belt cam pre- adjusted, I’ll try to work out how to tighten it and give it a go

Okay, so I’ve adjusted the timing belt. The weird sound is not as loud, so I may need to loosen it a bit more. The manual says, the origin is front left, but other people I have spoken to have used bottom left, so I’m not entirely sure. I’ve attached a screen shot of the origin setting.

So assuming the homing=front left. The coordinates are:
Home- X=0 Y=0
Front right- X=0 Y=200
Top right X=200 Y=200
Top left- X=200 Y=0

How are you differentiating front left from bottom left? We may be using different terminology…

Is this how the coordinates are coming?

Anyhow, after making the adjustments, are you able to jog without losing steps now?

Have you attempted any other laser operation like framing or a burn?

Are you still getting the same hard limit error as before?

Hi sorry for the late reply! Yes your diagram represents how i distinguish front left and top left. I don’t seem to be getting the hard limit trigger error. I think it was just a case of adjusting the timing belt. Thank you for your help!

Okay. Good to hear. Glad it’s working for you. I can’t honestly understand your coordinates but it should be okay as long as it’s not causing a problem.