Having Trouble Connecting Device

I have a second hand Red/Black Laser. I down loaded LB and tried to set up my device. I couldnt get it to connect. I connected the USB directly to the controller bypassing the plug and it connected. I was able to cut a couple things. I shut everything down and after reopening I can no longer connect. It sees the USB, but I cannot connect anymore I have a Ruida Controller

TIA Derek

Have you tried connecting using RDWorks? Also check that you are using a known good USB cable not exceeding 5 meters, unless using an active cable. Inspect and reseat each end.

This is worth review as well.

Thanks for the reply, I havnt tried RD works, is that a different software? The cord is about 4’ long. If i plug in the computer sees it but it doesnt say Ready, so i unplug and plug in numerous times before it will connect

Also tried to change those setting and was able to get into both of those, but couldnt find what i needed. Im sure they are there but I didnt see it

Did you install the driver at the end of the LightBurn installation?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.