Help connecting Bridge

I am having trouble in the last step of connecting to the bridge.
I changed my Ruida IP address to the correct address
I have done all the first steps of connecting to the LightBurn bridge wifi, and setting it to my wifi and password.
then it goes to the step “Scanning your network for LightBurn bridge devices”
The bar goes all the way across and then says that it is finished scanning.
It says “Select your device …from the list below”
but it never shows the device. I’m not sure what to do next. I’ve tried rebooting and going through the whole process several times and just can’t get to that last step to connect

Can you see the bridge on the lan? You would know the Bridge has connected to the lan.

If you can see it’s address, ssh to the pi (password is ‘raspberry’), I get this status screen…

Does the Ruida show ‘Lan: On’ in the bottom right hand corner of the controller window? This means it’s hardware is connected. Doesn’t appear to mean it’s talking. You can see the controller ‘activity’ on the LED lan, when it’s working.


says Lan on - top row.

I’m sorry, but I have no idea how to see what you are talking about when you say “Can you see the bridge on the lan? You would know the Bridge has connected to the lan.If you can see it’s address, ssh to the pi (password is ‘raspberry’), I get this status screen…”

the Ruida controller say Lan on, but I don;'t see anything in the bottom corner.

Don’t worry about the SSH thing - the key here is knowing what the IP address of the Bridge is so that we can get some status information from it.

But first we have to find that ip address.
One option is that your home network router usually will have a “connected devices” page or something similar and you would see a device called lightburnbridge there. If so, just type the IP address that it shows (something like into your browser address bar.

You could also try browsing to http://lightburnbridge.local
That doesn’t always work, depending on your network, but it might.

With either method, you would be able to see a dashboard giving you some status about the Bridge. If so, please screen shot that and share here.

If neither of those work, one last ditch option is to connect a monitor to the raspberry pi. Anything that will take an HDMI connect from the Pi will work. Connect it before powering on the Pi and you should see some boot up text scrolling by, then eventually the dashboard that @jkwilborn mentioned above. Take a picture and share that here.

Let’s start with hopefully one of those and we can go from there :slight_smile:

Thanks for this info… I am able top see my connected devices on my network and I do not see the lightburn bridge. I tried to connect it to my wifi several more times but its hard to know if it is connecting. Sometimes I get the text at the top of the screen that says Applying Changes… Your device will soon be online. If connection is unsuccessful… but nothing seems to happen. it just stays on that page. I’m guessing it is not connecting because when I then go look at connected devises it is not showing up.

my Pi-4 is on.
connected to laser via ethernet cable.
It is sending a signal because I am able to connect to it from my computer (or iPhone’s) wifi. but then once I point it to my wifi and give it my wifi password, I’m not sure it actually connects.

so I just tried following the SD card flashing instructions again.
made sure Ruida is set to
put SD card in Rasberry Pi
connected ethernet to laser and Pi
plugge Pi in
found Lightburn through computer wifi connection and attempted to connect it to my wifi with password. I think this is where I am getting stuck. It either just comes back to the wifi page or I get this message (see image) I don;'t think I am connected to the wifi. When I check my wifi for devices, I do not see Lightburn.

I believe the bridge will return to this screen if for whatever reason it cannot connect to your wifi network.

Are you absolutely certain you are using the correct password for your wifi? Can you double check this from another machine?

oh yes. absolutely certain. I just connected three new devices in the last couple days.

Perhaps try power cycling your wifi router. I’ve seen routers work fine on existing connections but start acting up with new connections.

What subnet is your wifi network on? Can you confirm encryption type for your wifi network? Is this WPA2?

Can you take full screenshots of each page as you’re working through the setup? Obscure out anything that might be sensitive.

mask is

I will have to try all this tonight and take photos. (gotta go to work)

This is where having a monitor connected is going to really help. You’ll be able to see, in real time, the wifi connection status. So if there’s any chance.
You don’t even need it connected to your laser when doing the WiFi part… hook it up to your TV. Surely that has an HDMI input. No keyboard or anything needed, just the display.

Excellent point. Use what you have available…

…but don’t call me Shirley…


ahhhhh… OK. I thought it had to be connected to the laser. I will do that tonight.

1 Like

I can’t see how to insert a picture. I believe this is doing what it should. I plugged it into my TV monitor and a whole bunch of text scrolled by and at the very end it says
network Wi-Fi config AP running lightBurn bridge 695C
control relay Ruida relay started laser IP: relay info: Ruito 1.0 and
raspberry pie no issues found @adammhaile @jkwilborn

You can drag and drop images to the edit window while posting. Alternatively, you can push the button that looks like this:

1 Like

Can you go through the configuration steps and take screenshots at each step? Might be some clue there.

Side question, have you ever connected to the Ruida via ethernet in the past?

Ok. I will. And no, I have not set up with Ethernet before. I’ve been using the USB. Do I need to make a change in the settings?

If you’ve setup the IP address on the Ruida that should cover it. I was more curious if you had something else setup that might be interfering.

When you get a chance can you take a photo of the Ruida IP Config page?