Help: Pause on apex when cutting circles

I have a Ruida controller and this issue has been with me since I owned the 50W blue Chinese laser.

When cutting circles the laser will momentarily pause at each of the four circle apex. So when cutting a circle in the counter or clockwise direction it will start right then top with a pause then move left then pause then bottom and pause and so forth. These pauses are very momentary and exaggerated the larger the circle.

I’m figuring there is a setting for this somewhere.


I’ve noticed this too. I think it’s how it calculates arcs. It needs to do 4 different 1/4 arcs or something like that. If there is a setting to change, that’d be swell.

The software represents circles as four splines (which are approximated arcs), so that part is true. The software uses tolerance-based subdivision to convert the splines into small linear segments, and because of how it works, all the segments end up being the same length and distance apart, so there’s nothing in the software doing this.

  • How fast are you cutting when this happens?
  • What size of circle?
  • Which model of Ruida controller do you have?

Do either of you have backlash compensation enabled in your controllers? If you did, the 4 points mentioned would be where the controller changes direction on one of the two axis. If the controller is emitting extra moves to take up backlash, it would have to stop because of a discontinuity in the motion path.

The left circle is what LightBurn generates and the right circle is how the controller would move if blacklash compensation was enabled. I’ve generated the machine path and put it into node edit mode so you can see the spacing of the emitted points:


Is this something I need on? .1mm is pretty insignificant.

That’s pretty small. Easy enough to try some test cuts and decide if you need it or not.

I can confirm that changing that to 0 lets my circles go all at one speed, with no hiccups or slowdown on the anchor points. Kinda nice. Really weird that it came with that option pre-set. Unless my predecessor had set it unknowingly.

I have no “backlash reapy” option enabled and the behavior is that the laser pauses at the four points OZ mentioned.

What Ruida controller do you have?

The setting Blake showed can be found in Edit > Machine Settings - If you have X Backlash or Y Backlash values that are non-zero, it’ll pause momentarily whenever an axis changes direction.

I have RUIDA controller version RDC6442S-B(EC)


This occurs regardless of speed but is more pronounced at higher speeds.

Circle size does not matter but more noticeable the larger the circle.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.