Help totally new to this

Totally new to this, got a universal engraver laser, doesn’t say laser type (think it’s gcode). Company won’t help getting it set up on Mac.

Is there a set to start first? Some sort of program before I can run LightBurn? Tried doing the find laser nothing pops up.

If someone could give me a “Laser for dummies “ version of what to do it would be helpful.

It would help if you gave us a ‘“What You Bought” For Dummies’.

Not knowing anything other than ‘universal engraver laser’ (which doesn’t exist in any plane) doesn’t really help us to help you.

A link to what you bought, at the very least.

In order for it to talk to LightBurn we’d need to know what kind of controller it has, or what firmware is running on it. I suspect this is one of the small diode machines, but they sometimes come with custom firmware, in which case LightBurn wouldn’t talk to it. As Bo says, a link to what you bought would be a good start.

Here is a screenshot, if you google universal engraver it pops right up.

Well, it says Windows, Mac & Linux (with VirtualBox). VirtualBox is a virtual machine that lets you install other OS’s on Windows, so either they mean Mac & Linux can use it with VirtualBox, or just Linux, but the wording is vague.

As a starting point, back out of the automatic device search, click “Create Manually”, choose GRBL-M3, enter the size and choose front-left for the origin. When you get back to the main screen you should see a box next to the “Devices” button that says “(Choose)”. Click that and see if any ports are listed.

Virtualbox runs on Mac and Linux, too.

It’s what I use if I ever am forced to use windows.

Have you tried asking them?

Thanks everyone I will give it a try and let you know. Yes I have gone round and round with company and all they say is watch a video that is over someone’s shoulder and doesn’t mention using Mac. Asked to return and they said they refuse…so no one buy from them lol.

How do I know what IP address to enter?

You can’t use an IP address with GRBL - it doesn’t support a network connection. You must not have chosen GRBL, but something else.

GRBL on a Mac is very straightforward.

Check ‘about this Mac’ > ‘system report’ > USB and see if the OS can see a device.

It’s probably an FTDI serial interface or similar.

I choose GBRL- M-3 like you said to 2 days ago.

Where is it asking you for an IP address?

It’s showing USB2.0-Serial

On the New Device Wizard writhing the manual setup

If it’s USB Serial, there won’t be anywhere for you to enter an IP address. That’s for networking.

If you are trying to add a profile manually and have selected GRBL-M3, you should not be presented with any questions about IP as this is not supported.

You may want to check that you have selected the correct profile to start with. GRBL-M3 will only present USB as a connection option.


Ok choose GRBL M-3 and got to enter work area and got to grid space and now when trying to do a test it says
There was a problem sending data to laser. The machine may be busy or paused.

Try another grbl-capable app, like chilipeppr for GRBL. It’s not a laser-capable app, but it will communicate and give you a live log of what the machine is saying.

So what I have discovered is the program they sent me to download is corrupt, and they say it’s fine but scans show virus after virus and corrupt files.

So… I guess I need programs that I can start from scratch with that will eventually let me use lightburn.

Should I take a picture of the device as it sits at my home? Picture of board on device?