Help with steps per rotation on roller rotary

Hello All,

I seem to be having trouble setting up my roller rotary. Here are is what im working with, im running lightburn(v 1.3.01) on a windows 11 pro Microsoft Surface. My laser is a custom built Further Fabrication Y-1200 Design with a Ruida RDC6445G(v 15.1.30) controller and a custom roller rotary. The machine works well with all tasks non rotary related but I tried setting up the rotary im not getting any expected results, the rotary is completing about 3.5 rotations on the cup and it does not matter whether I set the steps per rotation to 300 or 12000 or anything in between it still spins the same distance. Refer to the attached photos for more information. I have a Nema 17 stepper motor that does 200 steps per Rev. the stepper driver is set at 6400, the rollers are 44mm. I tried framing a rectangle that was 235.619mm which was the circumference of the cup(75mm dia.) and that too went around about 3.5 revolutions. I’ve tried making changes to the steps per rotation and doing test and I’ve also made the changes and the restarted the controller to see if that would help incase there was a software/hardware communication problem but that didn’t make a difference either. The rotary is plugged into the Y axis port.

Thanks in advance any help is much appreciated,
Wayne S.

You gave me all but one critcal number …

I’ll run over it quickly and put in a link to where I was more detailed…

Setting the steps/rotation.

  1. read the switches, compare to placard for steps/rotation
    a. this will be how many steps it will take to turn the motor one rotation.
  2. apply the missing gear ratio of the motor to the roller
  3. steps/rotation * gear ratio = Lightburn entry for steps/rotation in rotary gui

The only thing left to enter is the roller diameter…

If you have issues, sing out… :crazy_face:

Good luck


My stepper driver is 6400 steps per rotation.
My drive wheel is 60T
My Roller wheels are 40T

So 40/60=.66667
6400x.66667 =4266.67 should be my steps per rotation but like I said in the first post I don’t get what you would expect.

Using the rotary test button the cup rotates about 60mm and the hight appears to be 30mm. Closing out of the rotary window and testing a 235.619mm(circumference of cup) x 30mm rectangle it spins the cup about 3.5 times and the test is only about 10mm high instead of 30mm.

When you do this, have you tried the test button in the gui?

If that doesn’t produce the driving wheel to rotate 1 turn and back try to set the lightburn rotary gui to the 6400 steps/rotation and press the test button does the motor itself rotates 1 turn and back?

If these don’t produce the correct results we’ll have to look at it more closely.

Is this on the mug Y axes or the X axes… this should only be limited to the rotary axes.


Using the test button in the Rotary GUI I tried tests with the following steps per rotation just looking at the drive pully connected to the stepper: 4266(the calculated steps per rotation), 6400 and 12800. All of these attempts caused the pully to only spin about a third of the way around. The amount of rotation looked to be the exact same amount each time and then the motor would return to its original position after each test.

You have to get the motor to respond properly. Once the motor responds correctly then the ratio can be applied.

The motor driver controllers usually do this properly…

Are you sure of the proper motor? Don’t know how it couldn’t be workable. I can’t say I’ve seen this, it’s usually pretty straight forward.

I’m not sure what to suggest except we know the motor is not doing what it should.

Good luck


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.