Homing and general positioning problems on new DIY machine

Hi Guys. I’ve only just joined but I’ve been trying to use Lighburn on my home build machine with a Ruida RDC6442 controller for a good few hours now and am getting nowhere with my problems. I would describe myself as ‘lost’!

My machine has a work area of 650 x 500mm. I have limit switches on both axis and I can get the rails to stop when I press the switches. So far so good. However, I have the origin set as the front LH corner but if I ask it to ‘home’ it goes to the opposite corner (rear RH) and basically crashes. Both stepper drivers lose sync and lock out until I recycle power to the machine to reboot them. This also happens if I use the ‘set laser position’ with the cursor to place it in or around the centre of my work area on screen.

So, first question is how do I tell it I want to home to the rear LH corner and not the right? I can’t find anything in the docs or online. The second question would relate to the positioning error. What is going on there?

I also note that the LCD display powers up it shows values for XYZ as 10,000, 10,000 and 3,000mm respecively. That’s big! But what does it refer to??

for homing under edit-device settings

Hi Rob. Well that’s the funny thing; I read somewhere or in one of a dozen videos I’ve watched that the origin and home position are not necessarily the same thing. But I really don’t know!

I do know that by changing the polarity of the limit switches, polarity of buttons on the panel and motions etc I now have it homing in the top left as I desired. However, I have the origin as depicted by the red and green squares in the Lightburn software, at bottom left!

Another problem has been that when doing anything, the travel is pretty rapid and when homing for example, it crashes into the stops after hitting the limit switches, un-syncing the motors and getting the drivers to go into fault mode and locked out. I’ve just found out that there is an issue with scaling that is probably related; I’ve got speed set at 5mm/sec but in ten seconds it travels about 300mm. Clearly not correct. I now need to find out how to correct that.

I remain grateful for any input from anyone to my saga. Working alone with no one local to help is very isolated. I’m sure that eventually I’ll crack this. I just hope it’s sooner rather than later!!

Home and Origin on Ruida controllers are the same. Home and Origin on GCode controllers aren’t necessarily, so that’s a point of confusion.

All the settings you’re referring to are usually set by the manufacturer of the machine. If you’ve installed your own controller you’ll need to set up:

  • step length
  • motor polarity (direction)
  • axis lengths
  • speed limits
  • acceleration
  • laser tube type

All of these are available in Edit > Machine Settings in the vendor tab area. Ruida controllers generally home to the Lmt X- and Lmt Y- switches, so wherever these are is where your origin is.

Step length for each axis is in microns, and is the inverse of “steps per mm” that you see on GCode controllers. On my larger machine it was 6.35um per step, but this will vary wildly depending on the motor driver step settings and the pulley gearing for your axis.

little confused as to why you would change polarities on anything, they tend to be correct from the factory, crashing while homing tends to be simply a limit switch that is not working or bad wiring

Hi Rob.
“Correct from the factory” only applies if it’s from a factory. This is a complete from scratch design, crafted by my own hand. However, as my understanding of the controller builds so does my realisation that I may have made a couple of fundimental mistakes along the way. One of which is the wiring of the limit switches. I had nievely assumed that the home/origin position would be top left and switches further away would be positive. I think I got that wrong which is why swapping them and the polarity etc seems to correct it. A case of many wrongs making a right. I could have course rewire the switches on the controller but for now it works. I’m now onto trying to sort the speed and scaling of the motors. As I write, that’s not going well! It used to run but incorrectly, now it doesn’t run at all but makes a horrendous noise instead. I shall persevere!!

1 Like

Thanks Oz. I have to admit to learning loads on this. I just wish I was learning a bit quicker!

Update to the horrendous noise; if you input 0.12 instead of 12 microns as a step length value you get a screech that is in fact almost as impressive as it is scary! Having corrected this fundimental error I am pleased to say it’s now all looking much more healthy and even homes nicely. I wouldn’t be here if it wasn’t for your assistance. Thanks guys :slight_smile:

2 Likes