Homing is not working (Algo Laser Delta 22w)

Hi! i have a problem with my Algo Laser Delta 22w, im new in laser machines and i just bougth the machine 2 weeks ago, in the begining it seens to work correctly but sudenly for some reason the origin in the machine changes to (X=-660.00, Y=-660.00) (before that i try to adjust the belts) and every time i use the homing botton the machine try to go in that coordinates and moves only in the “Y” axis but for some reason the “X” axis doesn’t move and never gets to the lower left corner it stops when it collides with the bottom, i try to move it manually to the origin and in some point it seen to be solved but every time i reset the machine always detects that the origin is (-660.000, -660.00) and the problem start over, i try to set the new origin in ligthroom moving it manually but didn’t work, i also try to reset the settings in the controler with the comand “$RST=*” but didnt work. In the screenshots are the alarms that show me the console.

Hi !

If you disconnect the USB cable and only use power and LCD
Does the machine ttempt to home at all?

Belts are all tight?

I try several times to adjust the belts but to be honest i dont know what is the exact point or the perfect adjust for the belts and i just try to remove the usb cable and conect with wifi but only says waiting to conection but didnt conected at all

What is the behavior of the machine when just plugged to Power, not USB?

Assuming two key and emergency switch are in their disengaged position

sorry i could already do it, but the homing problem still the same and always try to get to the (-660.00, -660.00) coordinates

The issue is the following
Because you get -600x-600 means your homing failed

Any chance you could move laser head to the center and record a video of the power up sequence? Maybe upload to Youtube and post link?

Sure! this is the link

Do this for me, look inside the machine right behind the LCD

Make sure the Y-Motor/Rotary toggle is set to Y-Motor.

Then power on again.

It was in Y-motor, i turn it on again and still the same

I am sorry I am not really sure what I was thinking.
Your Y motor was moving already.

Can you double check your X cable is connected to the X motor.
Also, if you DO flip the switch from Y-motor to Rotary (This will quiet down the Y motor)
Can you hear the Laser trying to move the X axis or is all quiet?

Yes it seens the X cable is well connected and when i change to the rotary the X axis not move at all but makes a sound like its trying

Are you able to inspect under the laser and home it to see If the X motor shaft moves?

I assume you tightened the X belt correct with the right hand side tensioner?

I have done several tests and I have noticed that it squeaks in the part where the laser module goes, there where it shows in the image but I don’t know if that was really the problem.

It seems as if the X axis has no force and if i push it a little with my hand it moves forward but on its own it does not advance

It could be that the sprocket, the tooth part attached to the motor shaft, is loose.
If that is the case, the motor shaft will spin but will not “Pull” anything.

This is though a manufacturer got to give insights point
support@algolaser.com should be written to. You can point them to this thread

Ok i will contact them thank you!! i let you now if i can solve it

1 Like

Have you checked to insure that the mechanical shaft set screws are tightened? If they are loose, its not going to work correctly at all.

Yes, I already checked it and they seem well adjusted, I don’t know if I could put some lubricant on the band so that it would slide easier on the x axis?

I would not put lubricant on the band as it might degrade it. Does the assembly move easily, quietly and smoothly when you manually position it?

Sorry to step in.
I may be wrong but can you confirm if the yellow marked pin its a fixed pin or a idler pin?
And if its mounted like the other side. Just a guess, don’t know the system but seems a little diameter for the speeds and seems the belt is trapped between that pin and the roller.