Homing laser wrong corner and hitting gantry at speed

Hello, Newbie first time forum user and presently out of my depth.

Firstly Ruida KT332M controller not allowing access to it via the usual passwords RD 8888 RD1111 etc…
Machine Orion motor tech 80w.
Therefore using Lightburn can access and read controller and wrongly may have amended some settings, therefore ideally looking initially to reset controller to see if issue resolved, but without access a problem.

If no access then the actual issue is that the homing x and y instead of heading for top back right which would trip the sensors, heads at speed to front right belting against the gantry.

Tried several things from forums etc but suspect the more I fiddle the deeper I get.

Sensors working fine and by starting machine then stopping via stop button can center the laser and cut engrave from there. This error also happens when in Lightburn I attempt to reposition the laser head from the drag icon to place somewhere on the bed, it automatically heads at speed to bottom right hand hitting gantry.

Will stop there and seek guidance from the many laser experts out there.


Don’t reset the controller. You will loose all of the specific configuration data from the manufacturer of your laser. You will then have to go back to the manufacturer to get the proper information.

Before touching any configuration information, make a backup !

Why are you changing things… especially password protected configuration information?

Did you ‘write’ the changes back to the controller? If not, you didn’t change anything.

I’m also not sure if your controller uses the same password as the other Ruidas.

Is this a new machine? It didn’t ‘home’ “out of the box?”

If the Y axis is going the wrong direction, you can flip the one of the direction switches, but I would have to look that up. I believe it’s in the ‘machine settings’ and probably the “Vendor → Y axis → Direction polarity”. Sorry I just don’t remember and don’t have time to look it up… I changed mine when I modified the drive part of it, but don’t remember which it was other than it was the X axis.

Good luck


That is because you do not have a Ruida controller. You have a Ryxon (OEM by Ruida but customized and made for Ryxon).

That is a really really bad idea.

Check the Ryxon owner’s manual for configuring the homing of the controller. Evaluate if this is properly configured in yours.

Possibly, the default password to your controller is 123456

Hi Jack

Appreciate prompt response. Rank amateur I am afraid, didn’t back up and did I think, amend vendor settings,long story. Cannot access controller directly using RD 8888 does not work, but via RDWorks I can get access via RD8888.

Its actually Ryxon controller I am informed but apart from different buttons similar to the Ruida.

Asking manufacturer for password and if RD8888 then clearly controller problem.

Regardless as I say appreciate you replying.

A bit of a cheek but if you get a minute do you think you could screenshot the vendor settings of your machine? I could attempt via Lightburn ideally or RDWorks to set the machine up similar to your own while attempting to gain access directly to the controller.

Given settings amended anyway nothing ventured nothing gained.

Thanks again

Thank you for prompt response.

Yep as a newbie, didnt back up may have amended the vendor settings.

Tried 1 to 6 on controller and many others. Actually via RDWorks RD8888 gets me in which says possibly controller problem?

Was not aware there was a free Ryxon manual but have now found and downloaded, however if I have amended Vendor settings then will require to somehow get factory shipping settings or as I have asked from Jack that someone screenshot their settings and I will copy to controller via Lightburn.


Probably needs to be the same password :slight_smile:

Just picking on you… relax…

Ok you hosed the configuration. You need to find someone with a ‘like’ manufacturer. Have you attempted to contact the seller and see if they can help you?

The problem is that these machines a built based on a Chinese Government approved ‘design’. Meaning any manufacturer can pick and choose what they put into the machine. A friend that has messed with these for almost a decade advised that two identical looking machines may have up to 10mm difference in part placement and/or mounting holes, alignment or anywhere else.

The point here is that you need the original configuration, such as steps/mm etc. If you cannot find that you will have to figure it out or…

Hopefully you can find someone here that can get you a copy of their .lbset (lightburns machine settings, when you save it) That will hopefully get you up if not perfect.

Here’s mine for what it’s worth. It’s from my ‘China Blue’ 50 watt, 5030, which is different, but it’s a start. Have no clue as to the compatability.

blue-laser-machine-settings.lbset (12.7 KB)

I still wonder why it didn’t work in the first place?

Good luck, hang in there… :slight_smile:


Always use the most powerful tool on the planet before you fiddle with something…the Internet. Time spent there will save you many hours if not days or weeks.

I sense of humor certainly something you need when lasering.

I have contacted manufacturer and they asked, which password I required, explained the no access directly but also pointed out that even if gained direct access I would likely still need vendor shipped settings.

You never know they might just actually supply them (holds breath).

Again obliged for your settings which is as you say a start, will convert file and hopefully will read out alright to enter info.

Failing that did think about putting up another post asking for anyone with similar laser etc if the could post me or screenshot their vendor settings as you suggested.

Once again I thank you for your advice and information.

Despite initial set back looking forward to doing just that, moving forward.

Lets see. :+1:

Unless you and @jkwilborn have identical machines, his specific settings will only be enough to get you started at understanding the parameters and their effects. Perhaps this link in this post is as useful:

Your machine has specific stepper drivers, gear ratios, physical dimensions, triggers, etc that must be taken into consideration in various settings.

If it helps, here is how I have my Ruida 6445 currently configured (for the most part):


1 Like

Thank you, will check out the video like Matt’s videos very much, never contemplated checking out the ones re installing new controllers.

All excellent help fellas and learning a great deal every day.

If or when I get myself up and confidant, would look to help others such as myself before I leave this mortal coil,as you are doing for me.

Off to my cold garage to attempt all these options, never to old to learn, cheers.

You will be up, I have no doubt :slight_smile:
You need to loose that doubt

Tell me if I’m wrong, but I dropped the file there so you could read it via Lightburn and write it to your controller… Getting rid of the middle man (you.) :slight_smile:

Don’t tell me this doesn’t work…?


Quite right Jack the power of positive thinking, nothings impossible, even Scotland getting to the world cup next year. :joy:

1 Like

Hi, i have the same machine i believe, blue/grey Omtech 80 watt same controller.
I can upload a screenshot of the settings of mine in the morning, mine’s in the garage but no lighting (stops me being on it all night).

Chris, you should be able to ‘Edit → Machine Settings → Read’ it from your controller and ‘Save’ it to a file in the Machine Settings window. Just drop it to post it. Produces a .lbset file.

Roy should be able to ‘Load’ the file in lightburns Machine Settings and ‘Write’ it back to the controller. Keeps him from fat fingering things. :slight_smile:

Make sense?


1 Like

Cool, i’ll try that.
Just hoping my fingers aren’t as fat :rofl:

1 Like

Thank you Chris,Jack giving me credit for knowing how to open an lbset file in Lightburn.

In no rush and would if not to much trouble screenshots preferred. Technologies all well and good but nothing beats info in a hard copy.

Belts and braces.

Besides will be interesting to see the differences in the various set ups are compared to Jacks and Jeff’s.
Sympathise with the dark garage, know the feeling well., add cold and you have mine.

My current one is quite different in the X axes. I have run 1650mm/s with a acceleration of 50,000mm/s/s, that’s been changed in my controller now… :slight_smile:

Poops out above that, so max X axis speed is at 1650.


Not a problem.
I knew nothing about these things until a few months back, groundworks most of my life so hadn’t a clue and compared to most on here, still don’t :joy:
Soon be joining you i.e the cold weather, east anglia here. :slightly_smiling_face:

Can honestly say i have never tried at speeds above 500mm/sec.
Maybe i’ll give my fat fingers some exercise :thinking:

My machines been slightly modified.


I see you’ve been watching the ‘Russ’ videos :+1:
Seen every one he’s done and some several times.
you made that yourself?