Homing vs. Autofocus

I have a Omtech Polar laser cutter that uses the RDC6442S (panel added to it). I’ve been attempting to add an autofocus switch. I was able to wire up the switch to a z-axis limit, set the polarity, and get it to work as expected when I press run the ‘Autofocus’ command from the panel.

However, now, when I turn on the device, it autofocuses the z-axis down instead of homing the z-axis upwards. If I disable homing (via lightburn machine settings) for z-axis, the whole axis is disabled (including autofocus).

Does autofocus always just run the z-axis homing or can the two work in different directions with different limit switches? Or is it possible to disable startup homing but still keep the z-axis & autofocus on?

As far as I can tell, for Ruida systems, autofocus does exactly the same as auto-home does, which is to search for a Z- limit switch by moving in a Z negative direction and then set Z=0, the only difference is that autofocus is like a home followed by a secondary move to the ‘Focus Distance’.

If you changed the direction polarity then your Z movement will be in the opposite direction but from the controller’s perspective - homing and autofocussing will still be in a Z negative direction and searching for the same Z- limit switch. I’m guessing that you piggy-backed your new focus switch off the Z- limit switch wiring which would have been at the top if that’s the direction it was previously homing towards.

I don’t have that machine, but I’m guessing that if you now manually jog the head upwards (you may have to use the down-jog button to do this) it will hard-crash? since the controller will be will be now be waiting for and not finding a Z+ limit switch signal. If that is the case, I would recommend that you switch the wiring inputs for Limit Z+ with Limit Z- and this will mean you will have to piggyback your new autofocus switch off the bottom switch instead, which could remain in place as a backup to stop you from bottoming out if the autofocus switch failed.

You should be able to do this, I did test this on a Ruida RDC6442G controller I have and if you leave ‘Enable Homing’ enabled in LightBurn machine settings, but then use RDWorksV8 software to access User>Auxillary settings and set ‘Auto home z’ to ‘No’, that should stop the Z-homing on startup/reset.

Important: before you do that use ‘Read’ to read your current controller settings and then ‘Save’ to create a backup file before you use ‘Write’.

Disclaimer: If you follow anything I have suggested - it may or may not help - is not tested and likely to void any factory warranty… but I Iike where you are going with this - please keep us updated!


I didn’t even think about piggybacking. I had replaced the bottom Z- switch with the autofocus switch, but using both is a great idea.

Fantastic! This is the missing piece that’ll let me do what I want. I jumped right to Lightburn and haven’t ever run RDWorks, so it’s great to hear there’s more settings there.

Thank you, thank you, thank you.

So mechanically, is it that lower bottom switch that actually switches when the head is driven fully up?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.