Homing wainlux jl3 problem

Hello all
I am a newbie in laser engraving and bought myself a wainlux jl3 laser engraver.
But i have major problems in centering homing and setting up the device.
I already trye’d this forum and the biginners manual to try and fix my problem with the device.

The machine came with a faulty driver board and the machine being from china and making a dispute would take a long time ; so i decided to order a grbl 1.1 driverboard from makersspace annoy tools (also useable for cnc) and annoying it is.

I can only get it up and running partially.

Is there anyone that may have the trick to fix the homing and workspace ?

Already try’d the grbl setup tips and i believe my machine uses negative coord’s.
But again im new in this .

Please help.

I don’t understand the terms here.

Will it home to a specific place on power up?

You need to be more specific as to what it is actually doing.

Did you save the configuration from the original controller and reload them into the new controller?

This has little meaning what is ‘partially running’?

Does it power on and sit there, or does it try to move?


Hey there.
Sorry i am new new .
Everything works now but not how it should.
I discovered the working area is in a negative position.
So i used the help topic on setting up the machine.

Okay so it is a 30 watt diode laser .
Everytime i tryed to set it up it would run out of the workfield , meaning it want to run of the rails to i don’t know where.

I have 2 stop switches left up that should be my zero position.

No matter what i change it won’t home to that position and the size of the working field doesn’t match.

I have it working now but i mis is that the machine know’s it’s position in the workfield.

I have set it up in grbl unknown machine setup without end stop.

And the standby laser doesn’t work (low power raster laser)

So in order to let the machine work i need to make every picture really small choose my beginning manually and hope it won’t go out of the work area.
I also get the message working outside the workfield.

Long story short.

I can use the machine but not how i tought it should work.

Summed up: no standby laser
Workfield doesn’t match even when i manually measure the workspace and enter the distance in the console.
(Negative position).

And another problem besides these two is the offline console that i had to disconnect because of a error 24 communication fault.
Without it works okay (ish) and with i get error 24 everytime.

Did you put the ‘home’ switches to the back/left?

I’ve seen a similar machine and it was homing at the front/left.

Without limit switches (or disabled), it will never home and you will have to physically set it up 0, 0.

What help topic?

That can only happen in some mode other than absolute, as these controllers generally won’t allow an absolute negative movement.


Specific , okay .

No i did not download any settings from the original board because it have a fault that allow’s the Y axe to go outbound.
Still in dispute over that with the seller.
So i bought this grbl driverboard.
Yes i have the end stop’s installed and i measured with a multimeter if they work and they do.
I also measured the lead’s and connectors to and from the steppermotor’s also in good condition.

I used the help topic’s on lightburn website to get the machine working.
I learned that some grbl boards use negative position and so does my machine.

When turning on the power of the machine it does not automaticly home to X-0 Y-0

When i start using lightburn and setting up the machine it does home with the exeption that it stay’s there in place.

Even when i want to use the position tool in lightburn it stay’s at the end stop.

From here i started to try a little engraving.

Everytime the machine did a hard stop with the message out of workfield .

But if i look at the program all the dimensions in the workfield looked good.

So try’d again smaller picture corner left up where my end stop is but i manually choose to put it a bit out of range from the end stop.
I only got a picture when i placed the picture in the lightburn program almost outside the workfield.

None of the settings provided by the beginner topics worked out for me , exept the one where you don’t use a endstop.

And i used the console code to put the workfield in the negative position.

Now it works , but it does not home ( to endstop) , and i need to set the laser position manually in order to engrave something.

So in this picture i just typed the A .

But you can see according to the program i have a lot more workspace .

My real workspace on the machine is now using A4 format just for the letter A.
But it say’s the format is in mm , my conclusion is it is in cm (centimeter) so this could be software related.

I am sorry this is gonna be a long explenation .

In simple words , i can’t get my machine to home and keep track of it’s workspace .

And i can’t use the workspace in the program to completely fill with an artwork or multiple design’s
Because i don’t have a good look on any dimensions besides the mm that are displayed in the program.

I know , it is a weird problem .
And i needed a week to setup the machine to work in one way or the other.

It works but not how it should.

I just want the workfield on the machine to be the same as in the lightburn program.

And if possible use the diode laser to point out the frame when i use the frame command in lightburn.

Either way i learned to work around some of these problems and gonna buy the program.
But i would like to see everything work correct.

About the homing switches back left , and that is the only place i can put them from how the machine is built.

There are all of the $ configuration that have nothing to do with the error mentioned. If possible you should attempt to plug that board back into your computer and save those configuration numbers.

99% of the time we find these are not configured properly.

Does this mean the manufacturer had a place there or it was a good place for you to put them?
I.E. is that were the manufacturer designed them to be or where you decided you’d like them?

Might want to post a screenshot of the Edit → Device Settings

The micros running grbl that I have read use integer numbers for the absolute position of the machine. This means there is no ‘negative’ values.

It sounds like you have limit switches turned off in the configuration, so it will never home.

You need to do this one step at a time. First it must home properly. As I mention previously, I thought those machines homed to the front left…?

I can see the limit switches in the ‘aerial’ photo.


This machine in original state home’s to left and up

And yes i manually disabled homing because when on it would go outbound everytime or just sit at X-0 Y-0

But it still wanted to go further up , the only thing stopping it was the stop switch

It doesn’t sound like it’s seeing the home switches.

It can’t do two different things on boot, either it goes ‘outbound’ or it just sits?

You need to post it from ‘Edit → Device Settings’ not from the laser window.


Don’t complicate things, lets fix the homing problem. That might fix many things.

Can you post the ‘Edit → Device Settings’?


1 Like

Hey Jack sorry , i was out of messages because im a new user .
I will post pictures when i have time for it .
I am very busy in my regular job.
Thanks in advance.

No problem, get to it when you can…

Maybe @LightBurn can change it so you can post what you need.


@Lightburn and @jkwilborn ,
On startup my machine won’t home.
I did the machine setup numerous times without luck.
I can give it a homing side , but it always home’s the wrong way no matter what side i choose in the software.

My problem now is , it doesn’t have a known workingfield .
Everything else work’s fine .

When i give the command to let the laser go to a certain position in the field it now home’s to the up right corner .
Doesn’t matter what position in the field i choose.

I will post a picture of the message in the console .
I think i need to give the laser his position manually in the console but i have no clue on hiw and with what command.

In my test setup i have this message.

Also my text’s are mirore’d

You should go through lightburn Common Grbl setups (I believe it’s a grbl machine). This also contains instructions for machines with no limit switches that can’t home.

After that their Coordinate and Job Origin document.

You say it won’t ‘home’, but you use ‘home’ many times in your reference. Let’s be on the same page.

When a machine ‘homes’ it knows the 0, 0 position of the machine and that determines the quadrant of operation. If it can’t home, it’s limited to what it can do. Homing requires ‘limit’ switches to be installed on your machine. If it has homing switches, then you don’t get to chose which is the ‘home’ corner.

Wrong quadrant can cause the image to be flipped.

Is this a new machine, did it ever home?

Hang in there. These simple machine can be mind benders even to experienced users.

Hopefully the links will be helpful.

Good luck.