How do I get to the $ settings? Can I lock windows in place?

Trying to locate the $ settings to set my home position etc…They are no longer in the prefs folder apparently.

Also, is there a way to lock my Laser, move, cuts/layers, etc. windows in place so when I click on them they don’t move all over the screen.or disappear completely?

The file is likely still there. The quick way is to check where the lbprefs file is located.

If you open the C drive in Windows Explorer and search for lbprefs you can select a file with a date that matches when it was working well for you.

It’s likely that Windows misplaced the link after a windows update.

Please grab a screen capture with a tool like Windows Snip and drag that pic into a reply here. The LightBurn windows dock and they change state and stay put when docked. Sometimes the size of the window (or a small laptop monitor) contributes to making it an exercise in patience to get them docked.

A screen cap will show me if they’re docked or still floating. The behavior you’re describing sounds like they’re floating so I’d like to confirm.

Thank you John for the reply. This is a new download of LB. I was playing around with it a couple years ago(trial version) and could adjust everything through the $ settings. Trial expired, life happened, etc… I just downloaded the newest trial



version to make sure it will work with my new miniGRBL board but now I cannot adjust my home position(or anything else for that matter) because there are no $ settings. I will also attach a screenshot of the mess that is in my prefs folder as well. I have very little experience with LB but am pretty sure it’s the software I want to use as long as I can configure it to my liking. It seems fairly similar to the cnc software I have been using for years.
PS. I don’t know how to dock the windows either. Thanks again.

1 Like

The GCode license should be the one you need. It won’t be the Galvo license or the DSP license. if you have a link to the board or the docs for it I should be able to confirm.

Click (hold) and drag the undocked window by the tool bar and hover the tool bar over the working area of the docked window. When the docked window changes state (turns blue) release the mouse button, it should snap the undocked window into that place.

From the screen cap it appears you haven’t connected. If you’re still fighting it, please select a different COM port (bottom middle of the Laser window) and watch the Console window for the connection message. Wait five or more seconds before trying the next one. If you have other software open or running it may have claimed the USB port making the laser engraver unavailable to LightBurn.

When you connect the $$ command will likely work. There are a few GCode based controllers that won’t return information when polled with this command.

One last fun thought.

Please drag and drop that prefs file into your current version of LightBurn.
I’d like to see if it imports it. :slight_smile:

It will connect. I didn’t have my laser powered on when I took the screenshot. Thank you for the info on locking the windows. Much better!

1 Like

The screen shot of the prefs folder is in the current version. I just checked it again with the laser on and connected and it is still the same. Is it due to this being the trial version? The old trial version I used in 2020(v0.9.20) had all the $ settings and was quite easy to configure. Thank you again for the help.

If it connects, capture some of the message in the Console window.
Some engravers don’t use $$ to communicate settings.

I’d like to see which engraver you have and which firmware number appears in the ‘welcome’ or initial connection message.

Here is what I have. I know it uses $ settings because the board install advice from Awesometech instructed me on how to set up “home”. With my new install of LB, my machine thinks home is inches away from actual home.

Still no $ settings. Does anybody know why or how to access them?

You can check these in Edit->Machine Settings or by issuing a $$ command in Console.

1 Like

I’ll check the MiniGerbil docs.
I’m not 100% certain the $$ settings are available.
Were you using this same engraver previously?

When I enter $$ in the console window, it tells me what they are set at but I want to know how to change some of them.

Yes sir, same engraver, same board, same pc, the only thing different is the version of LB.

What are you trying to change? If you’re not familiar with GRBL configurations then making changes is not advisable.

Also, did you check Edit->Machine Settings?

I want to change my home position(distance from the limit switches) for starters.

I’d suggest you take a backup of the configuration before making changes:

  1. You can do this from Edit->Machine Settings
  2. Save the text output of $$ command

Here’s a reference for you:
grbl/settings.md at master · gnea/grbl · GitHub

Homing pull-off distance is $27.