How do I position my laser home point

I have tried all different setting but can not get my laser to recognise where it is, I can burn images but it seems to burn them in random positions, and I don’t understand why or how to set an origin point for the laser to return to, when it has finished an image or just a straight line it stops and stays there, and will start the next project from that point

1 Like

If you look on the “Move” tab there is a “Set Origin” and “Clear Origin” as well as a “Set Finish Position.” I’m guessing you have a GRBL machine without limit switches to home to?

Does your machine have homing switches? If not, you’ll either need to power up with the head at the home position, or jog the head to home and enter G92 X0 Y0 into the console and press enter. That sets the zero coordinate of the machine, and will allow you to use User Origin or Absolute Coords modes. Otherwise, just use ‘Current Position’ mode.

https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

Thanks for your reply. The “move” tab I have only has Get position and below it it says move to position, yes I do have a GRBL machine without limit switch’s

No matter how I manualy position the laser head it mac
kes no difference.
I placed the laser head bottom left and then try to burn a line from left bottom to top right but it wants to burn to the left and hits the bolts.

Thanks for your reply. no my machine has no homing switch, I tried positioning the head to home and did as you said and entered G92 X0 Y0 but it made no difference, I set it to bottom left the drew a line from bottom left to top right but it tried to burn from bottom left and go further left.

I just don’t know what to do now, I have even tried uninstalling and re installing lightburn but that made no difference, on re installation I still had the same readings,

Sounds like one of your motors might be running in reverse.

Put the head in the middle of the bed, turn it on, and then move X+ 10mm and note what direction it moves. Do the same for Y. Whichever corner they’d hit by going down in both directions is your 0,0.

This will do nothing. The settings in your controller aren’t correct, that’s the only issue here. Because your machine does not home or zero itself, you have to do this manually, and you have to set the settings correct so that LightBurn reads the proper numbers from the controller.

What version of GRBL are you using? If it’s 0.9, the command you need is $10=2. If it’s 1.1, the command you need is $10=0. Once you set that value, LightBurn will be able to read the position of your machine relative to the zero point you set using the G92 X0 Y0 command, and it should work.

The other option (possibly simpler) is to use ‘Current Position’ mode to run jobs, which is described in the link I sent before.

Thank you for that, I will do as you say, do you think this would be why one of my step motors is running the wrong way now

Thanks, yes motor is running in reverse,would you know how to correctthis tia

It looks like $3 can do so in software. Direction invert mask.

Hi I went into the controller settings and x axis is $3 t clicked in the box marked false and that has corrected the directuion, thanks for pointing me in the right direction.

I have set up my origin and it returning after a cut woopee. the only strange thing I now have to cure is that when I draw a line or place an image the origin point goes with it, so everything engraves from the zero point

Awesome, glad to hear it’s working.

I think your remaining issue may have to do with the link from Oz? That or you have “Return to finish position” in Device Settings on and haven’t set that maybe? <-- Just guessing.
https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html