How to collect.rd files from a Ruida controller - not delete

I had unusual cutting defects where the job shifted several mm during the execution of the job. I have seen this on two different machines that each use a different model Ruida controller. On the most recent event, I was able to see the cut error in the little picture that appears on the controller. I resent the job using a different name and it did not have the defect. Now I want to pull both files from the controller so I can do a diff on them and get closer to root cause. I can see both in the Files window, but there is not an “download” button" to pull the files off the controller.

Any suggestions for how to accomplish this?

You have to go to the machine console and use a usb memory stick.

Press ‘file’ and the bottom option is ‘copy to udisk’…

There is no way I know of to read it back to your computer…

Good luck


I have been trying to do this very thing for months, without success. I opened a trouble ticket with OMTECH, but in the end, their response was “we don’t know why it doesn’t work” and they sent me some money. Jack is right, there is a “copy to Udisk” in the menu, but every time I tried it, I got a “copy failure” error message. The last message from them was that you can’t use anything larger than a 4 gb thumb drive (I used the one they sent me with my laser), but nothing worked. I will be interested if you can get it to work.

Thanks for the suggestions. I won;t be able to test them out until next Tuesday, but I’ll let you know. Meanwhile, I’ve also got a second method to try next week. I downloaded Ruida’s RDWorks software and it appears to have an upload capability in it’s “file” window. I’ll try this too.

OMTECH suggested that as well, I was able to see (read) the files on my MF1220-50 but had the same issue. The upload would either fail or I ended up with a 0 byte file. It may just be my machine or the series of controller that I have (RDC6442G-B), so I’m really curious if it works for someone else.

I have a 6442g-b(ec). I’m using a 8GB stick, it’s formatted to FAT32.


This is what I get from nautilus when I read the usb stick.

Screenshot from 2022-10-06 09-53-34

The Ruida manual

This system supports such file formats of Udisk as FAT32 and FAT16, but it can identify them when the files are put under the root directory of Udisk. The file name of more than 8 characters will automatically be cut out by the system. The file name that has only English letters and digits will not how when they are copied to the mainboard. The files copied from the mainboard to Udisk will be placed under the root directory of Udisk

Mine seems to work…


Good deal :+1:, I tried for about a month or so, and had 5 or 6 email conversations back and forth with OMTECH, to no avail. At one point they told me my main board was more than likely bad, wanted me to take it out, ship it to them, and then wait for them to send one back. When I told them I couldn’t be down that long and would they cross ship, they decided that there was no point, they were all probably that way. So, OMTECH offered me some money for my troubles, and called it a day. I’m glad to see that it’s working as it should for some folks. I suspect that I have a bad main board because it will start to send the file, I’ll get a couple dots on the progress bar, and then it throws a “copy failure” error.

Doubt this is a fix, but it’s a simple confirmation…

The udrive cable plugs into a standard usb port on the Ruida. If you have room plug the usb stick directly into the controller. That will remove any chance of it being a cable or connector issue.

Ensure the stick is formatted properly for fat32. It will only read/write to the root directory of the stick.

Are you on the same firmware?


I’ll check. And I did try plugging it directly into the controller, same result (I did confirm fat32 and used a freshly formatted thumb drive). I honestly didn’t mean to hijack the OP’s thread :laughing:.

I have a 6442G-B (ec) as well. I can copy files to the controller using Udisk, but I can’t copy files from the controller using the “copy to Udisk” menu function. It looks like we are on the same firmware version.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.