How to correct the amount of movement of X and Y

When cutting a square or a perfect circle by laser processing, if the shape cut out due to the habit of the machine is slightly different between the vertical dimension and the horizontal dimension, or if it is not a perfect circle, the movement amount of X or Y only is corrected by LightBurn. Is there a way to set it with?

If I am reading your question correctly, this should help

Thank you for your response.
I didn’t notice the function of “calibrated axis”.
Thanks to you, it seems that beautiful processing can be done.
I’m really thankful to you.

When calibrating an axis from experience use as long a test line as possible.

eg if your bed is 900 x 600, use a line say 800 or 850 on the X Axis, 550 on Y, this will give a much better calibration than doing a 100mm box for example.

If you used a small box to calibrate, I suggest you run a long line and measure it.
I did a 100 x 100 box, set it perfect on the verneir calipers, then tested a 800mm line and it was 6mm short!

Thank you for your very meaningful advice.
Currently, even a small perfect circle hole can be clearly seen as an ellipse.
Based on your advice, I will repeat the adjustment for more perfect processing.
Thank you very much.

After performing the axis calibration, the laser machine behaves strangely.

After inputting and saving the target dimension and the actual movement dimension for each of the X-axis and Y-axis in the axis calibration, the machine, especially the Y-axis, does not work properly.
(I think the numbers you entered are correct)

As a phenomenon
The machine’s home return works normally.
When I place the shape within the machining range and press the “frame” button, the X-axis tries to go to the normal position, but the Y-axis tries to move out of the machine’s operating range.
(If I don’t press the stop button to force it to stop, it will try to go on forever)

In the “Move” tab, If I do not enter anything in the Y axis and enter the movement distance only in the X axis and move it, the Y axis will also move freely outside the operating range of the machine.

The phenomenon does not change even if the personal computer, ImageBurn software, and laser machine are restarted.

It is the same even if ImageBurn is deleted and reinstalled once.

Is there a way to reset all ImageBurn settings to their initial state?
Or was the controller of the laser machine rewritten with strange data?
In the current state, laser processing is no longer possible.

This is the full reset:

Before you reset, Are you working in mm?

Can you unplug the stepper motor power and laser power from the engraver so your computer communicates peacefully with just the controller? The computer can ask what the axis settings are if you open the Console window and enter $$. Please copy and paste the results from the engraver controller here.

Thank you for your prompt response.
I deleted the two ini files in the prefs folder and tried to initialize them.
After that, I re-registered the laser, but the result was still abnormal and did not change at all.
After all, the Y-axis will move freely outside the operating range.

Before initialization, I tried to extract the controller information in the console window as advised.
I’m not sure if this information is okay, but I’ll paste it.

$ 0 = 10
$ 1 = 200
$ 2 = 0
$ 3 = 7
$ 4 = 0
$ 5 = 0
$ 6 = 0
$ 10 = 1
$ 11 = 0.010
$ 12 = 0.002
$ 13 = 0
$ 20 = 0
$ 21 = 0
$ 22 = 1
$ 23 = 1
$ 24 = 100.000
$ 25 = 1000.000
$ 26 = 250
$ 27 = 1.000
$ 30 = 1000
$ 31 = 0
$ 32 = 1
$ 100 = 88.643
$ 101 = 115.889
$ 102 = 80.000
$ 110 = 4000.000
$ 111 = 4000.000
$ 112 = 4000.000
$ 120 = 200.000
$ 121 = 200.000
$ 122 = 200.000
$ 130 = 810.000
$ 131 = 460.000
$ 132 = 150.000

I think $ 100 and $ 101 are the number of steps per unit of movement to each of the X and Y axes.

Yes. That’s correct.

Can you confirm that you have the standard Laser Master 2? If so, default for these should be 80. Even with adjustment it should be fairly close to 80. The Y value $101 looks much too large.

You may want to change both of these again to 80 and recalibrate.

These set your X,Y,Z Max travel. You can ignore Z but 810,460 mm for X,Y is too large for OLM2.

Normally these would be 400,430. This may be why your laser is travelling beyond the frame. This should also match the work size in Device Settings.

1 Like

indeed, and these are what the rest of the codes are:

Some of your numbers are very unusual.

Typing $RST=$ into the console window will change it back to factory settings it appears that @berainlb has shown you the safer path. Here is some further reading if you are interested in making other changes or resetting them.

Thank you for your very detailed response.

The machine this time is NEJE Master 2s (A40640), which has an original work area of ​​460X810 and is set to 440X760 for safety.
This time, the set dimensions and the actual machining dimensions were a little different, so I just adjusted it by axis calibration.
Did doing that change even any of the other settings?

The serial terminal is grbl, so it worked fine so far.

I’m not very familiar with these settings, so there are many things I don’t understand, but I’d like to try them out little by little.
I think the first step is to eliminate the phenomenon that the Y-axis moves freely every time something is done.

Based on the advice I received, I would like to try various things.
thank you very much.

If you get stuck again, I would be grateful if you could give me some advice.

This should only change a single GRBL parameter, either $100 or $101 based on X or Y. You can change those values directly to tune the size. Other parameters should not change.

That makes sense. You can probably safely change $101 to match $100 and then tune again.

You may want to take a backup of the settings in Edit->Machine Settings before making more changes.

When I verified the operation of the machine while changing various setting items, I was able to understand it little by little.
It seems that the values changed in the device settings are not reflected in the values in some machine settings.
Regarding the calibration of the amount of movement, I felt that it was better to write the numerical value directly in the input window and set it rather than the axis calibration.
(If do it properly, there should be no problem)
I would like to calibrate by operating while changing the numerical value directly little by little.

Thanks to the accurate advice, I have learned the technique little by little.
Thanks to everyone, I managed to get it working properly.
I’m really thankful to you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.