How to get inverse fill to follow outline without waste

I have an fill layer I am trying to reverse

I know i can put a box around it and get this

Which does put most of the fill where i want it but it does not follow the cut outs of the original edges and it also has a ton of fill that is just a complete waste of time. Is there a way to get the fill i want to follow the edges with the tabs and not have so much fill where its not needed.

Here is the file

UR_Box.lbrn2 (597.5 KB)

Try using the offset shapes tool on the outline just offset it in 0.01 inches.

Just duplicating the outside line on top of itself should do it.

Having a solid understanding of how LightBurn uses shape boundaries to toggle On and Off the fill process might be help.

It does not i already tried that

Rick, i understand what you are saying but the only way i can get it to invert in the file i actually posted is to put a full box around it, if i copy and past in place the outer line with the shapes it will not invert the file, i want the outer shape of the fill to match the shape with the cuts not a huge rectangle that makes it burn wood for no reason.


I tried that as well

This is a bit confusing. I see you have the outer-most shape (Layer 07) set to fill. Is that what you intend, as I would expect that shape to be the cutout line? Additionally, that set of shapes reports as not closed, so this will not fill as you currently have constructed if in fact, you want the 07 Layer to fill. I also notice you have shapes duplicated on top of each other. Is this intended as well?

Please show an example of how you want the outcome to produce, and we can point you in the correct direction.


Here I have ungrouped, then moved the pink shapes up and to the left to be able to see them.

Rick, its 2 different layers i just turn one off to see the other. I intend to run the fill layer first pink then turn it off and run the green engrave layer after that.

Is the outside shape not really closed then?
If you click Edit > Select open shapes, does it highlight that outline?

The outer-most shape is not closed and all shapes that make up that outer shape are duplicated on top of each other.

The tell…, the flashing marquee. Break this entire shape apart and start moving things around, you will see what I have found. :wink:

Rick, i see that the green stuff is not my design its imported and it looks like the outer shape was not closed the purple lines are copy paste in place from the green then layer change on the result so it carried over. Now when i select the outer line it picks the whole thing and not just a piece of it and there is no group.

All that being said it I am back where is started, it still isn’t filling where i want it if you look at the purple layer i need the exact opposite the boxes and diamonds should be no filled and the frame around them should be filled, i can get that if i draw another frame around the whole thing on purple layer but then i lose the original shape.

If i select open shapes it selects the outer shape and the boxes above it on the green layer but i cannot see why and i tried the options to join shapes etc

UR_Box.lbrn2 (414.7 KB)

Thanks everyone for the help, i did get the file to do what i wanted but unfortunately i do not know what i specifically did, it just started working at some point.

UR_Box.lbrn2 (479.8 KB)

I duplicated the outer-most green shape, then placed on pink layer to produce:

Part of the issue may be using filled rendering, it covers things up. I had a few small things still behind others. UR_Box-1a.lbrn2 (482.2 KB)

Rick, i will look at turning off that feature for sure i really don’t know what fixed it i did find a tiny line that i deleted all by itself that wasn’t visible unless you really zoomed in that may have done it. If the red in your post is shading then its backwards to my desired output, the purple is perfect now in my last post. I am aiming at making the diamonds and the squares with the symbols little islands in 3d relieve so I am taking a layer of wood off around them the red in your output is still shading areas where the diamonds are outside the border lines.

I think it was something i was doing with the line tool, when i tried to do a preview this time it said there was one shape that was not closed, when i clicked the show me link it was a tiny line on the left border vertical when i deleted it i no longer get any errors before the preview. I must be leaving little lines everywhere when i was using the line tool.

It is not, it is showing Traversal Moves.

My bad, it looked like shading to me.

I guess i have some learning to do on the line tool but i have optimization down pretty good got the transversal moves down to a little more than 9 minutes. LB rocks once you learn how to use it properly lol.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.