How to get simultaneous fill and line when using Ortur YYR Rotary Roller

I’ve recently started using the Otur YRR Roller and just can’t solve this problem. As a test, I have created the alphabet to be burned around the circumference of a simple solid wooden cylinder. The rotary settings have been adjusted, so that the last letter Z is a similar space from the first letter A. That is as far as filling the letters is concerned. However, when the laser carries out the line (outlining each letter) is starts on Z and aligns perfectly. However as it works its way aback up the alphabet to A, it gains distance (in the Y axis) so that when it reaches the A fill, the outline is a whole character to the left.
I’ve burned the same alphabet on flat wood and it’s perfect, so it’s something to do with using the YRR. I’ve adjusted the YRR belt from quite loose to quite tight. I have reduced Y speed and acceleration. I carried out tests and noted that for the return rotary direction, the YYR does not return the cylinder to quite the same place as the start and have therefore concluded that placing my test wood and future items on Ortur YYR is not going to accurate enough for small fill and line, unless I can avoid the return rotation.

If I burn the alphabet with fill only, there is no problem, but I need that crisp edge to the characters which line gives.

I would like to set Lightburn so that it starts by filling the first character A and then burning the line around it, before moving on to B and so on. This would then avoid the full return rotation which causes the inaccuracy between fill and burn. I have experimented with Optimisation Settings and Fill all shapes: at once/groups together/individually, but can’t get what I’m afer.

Any ideas/settings please?

You can ungroup the text and make each letter it’s own layer. It will complete one letter at a time.

Thanks. I thought of that, but I don’t think it’s a solution for me for 2 reasons: -

  1. The text has been established with the create / edit text tool and when I right click it, the ungroup command is greyed out, so it appears not to be possible to ungroup text written the conventional way.
  2. Even if the above were possible, 26 separate layers is just within the capability of Lightburn layers (29) and would really be impractical to allocate each letter of the alphabet to a separate layer. Furthermore, what if I wished to place a hundred or more small graphical items around the circumference of my work? I need the line and fill to be carried out pretty much at the same time.

With the text block highlighted, click on Arrange, then Break Apart. The letters will be in many pieces. Create a box around each letter and Group it back to a complete letter. Do this for each letter. You don’t have to put every letter on it’s own layer. Your problem is when moving too far on the Y axis. Put letters in the same vertical plain or Y axis on the same layer, so it completes a column you grouped at a time. Depending on how many columns you have will determine how many layers. Probably not fun, but will work.

Thanks, I tried this. Break apart was greyed out. However, if I click “unlock selected shapes” first, it became available. Each part of each letter was now a separate line. I grouped all the parts of each letter and put it on a separate layer. However, when I preview the burn, I get the error “Open shapes skipped” “*** shape(s) were set to fill, but weren’t closed. These have been removed as they cause problems” I can cancel or continue, but I only get the outline of the letter burned with no fill.

Sorry for the bad advice. I’ve been teaching myself Carveco lately for my new CNC, and that would have worked on that.
Just put each letter in it’s own text box. You can still group them layer wise vertically to keep layers down. You’ll just have to work a little harder to align them all.

Thanks - Yes putting each letter in its own text box and then allocating each one to a separate layer and then setting “optimization settings” to “Order by Layer” gives just about enough accuracy, but what a pain! Also say I wanted 100 leaves burned around the circumference - this method is not practical. I’ve raised a ticket with Ortur regarding the YRR turning more in one direction than the other. If it was the same, then perhaps a solution to the line/fill sequence wouldn’t be so important. I’ve not heard anything from the Lightburn staff - come on guys please - how do you get the line to burn just after each bit of fill and not wait until the fill is complete?

There is no setting for this. Fill+Line will always run the fill first, then the line.

One possible way would be to use two layers - set one to fill and the other to line, set the fill to fill shapes individually, then remove “Order by Layer” in the Optimization window, so the software is free to order how it wants to. If you grouped each pair, you could set “Order by Group” and that would work too.

Hi Oz - thank you for your reply.
I was convinced the stepper motor of the YRR was at fault, but as your colleagues have advised me by email, the problem is poor friction between the smooth plastic rollers and my lightweight wood cylinder. As an experiment, I applied a couple of pieces of very thin double-sided tape around the wood and achieved perfect registration between fill and line, even at normal speed and acceleration settings. Now I can see it’s a matter of friction, I will consider and research increasing the friction of the YRR rollers.

That was also me, via email. :slight_smile:

Ha! - I thought it might be, but as the emails weren’t personally signed, I couldn’t be sure. :grinning: