How to keep my work zero

1 last question how to keep my work zero. If I walk thru and set my work zero and start a project and decide that maybe it is not burning dark enough and as far as I know you can not speed up or slow the laser down in progress so I stop the carve. How do I get the laser back to work zero without having to manually reset it. If someone will point me in the right direction it would be great…

Use “User Origin” or “Absolute Coords” as the “Start From” setting. Both are fully repeatable. If you are using “Current Position” there’s no simple way for it to go back there if you stop and restart the job.

https://lightburnsoftware.github.io/NewDocs/CoordinatesOrigin.html

1 Like

Thanks for the quick reply.

Very easily if you’re using a Ruida DSP.

Before you start a job, press the origin
Button on the HMI. There, you just saved the current X Y Z positions.

Now move the laser head around, run job, stop a job, etc… wanna go back to that exact spot again? Hit the escape button on the HMI twice.

Thanks Jeff but i don’t seem to have an escape button.

XCarve isn’t using a Ruida lol.

No matter if i use set origin or finish position it heads up to the lower corner. Should i home the machine first?

Ahhhh. A detail I overlooked! :upside_down_face:

Ok i am reading and trying to figure things out. I just read about setting $30>1000 if you are running 101f and i am running 101g at 255 is that correct or should i change the value to 1000?

That value just needs to match whatever you have set in your device settings for “S-Value Max”.

The number is mostly irrelevant, as long as it’s not tiny (like 1 or 2), and the software and firmware both agree on what it is. (The S-value max setting in the Device Settings in LightBurn has to be set to the same number as the $30 setting in the firmware).

Back up a little - Do you have the X-Carve set properly for LightBurn? The origin should be front-left, and yes, you would absolutely have to home it and set an origin offset to use User Origin or Absolute Coords. Instructions for this are here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

Thanks Blake i have my $30=255 and my s-value at 1000 so i need to change one of them to match correct?

Ok i have the origin set to front left. I am thinking maybe i need to go thru and reset this up for an xcarve 1000mm. Need to figure out how to start all over. I have been using the program for a while but not sure i have it set up correct.

If you click the ‘Devices’ button and just delete the device you have, then re-start the program it will automatically walk you through it.

1 Like

One last question to get me going. I do not work in mm i am an inch person. So i have a xcarve 1000mm do you know the size of workspace?

Type $$ and look at the settings $130 and $131 - those are the travel limits in mm (which LightBurn will automatically get for you when you auto-configure the device)

Just wondering Oz - I frequently stop a job (Ruida 6442) by pressing Pause button on controller and if I need to restart it from origin just press escape and it reverts to the original start position which is usually “Current Position” in LB.
Maybe I’m not getting the gist of Wayne’s question though???
Also he can alter both speed and power while the job is running by using the (Ruida again) controller buttons.
Just FWIW

The original poster isn’t using a DSP laser controller, so the behavior is quite a bit different, and the starting position isn’t retained like it is with a Ruida.

1 Like

Ah…The penny drops!! Thanks for clarifying.

Ok i think i have everything worked out for now. They kicked me off yesterday for asking to many questions for a newbie. Lol Anyway i am running grbl 1.1g is that newer then the 1.1f? Tryied a picture a while back and wondering if that was my problem may need to switch to the later.