How to NOT print toolpath between objects

I am evaluating Lightburn. I really like this software and it works well with my grbl laser.

When I created a Text and engraved it, the toolpath travel lines continued to burn as the laser traveled between each text letter. Normally the laser would stop burning until it travels and reaches the next letter then the laser powers on to continue burning the next text letter. How do I stop this from happening???


Chances are that you’re using an older version of GRBL on your machine, meaning you’d need to use the GRBL-M3 device in LightBurn.

You might also need to set the S-Value Max setting in LightBurn. This topic covers this well:

Thank you Oz. I just flashed the GRBL to 1.1f.

I still had the same travel lines showing problem. I then used the Console and changed $32 = 0 to $32 = 1. That removed the travel lines.

However, the laser engraving is like the the power has been reduced. I then went to the Cuts Window and saw the Power Max went down to 20. I put it back to 100. but it is still burning lighter than it did before.

Is there any suggestions to get the power up so it was engraving like before?


You can use the GRBL-M3 device instead of “GRBL”, and that will turn off velocity ramping.

Something to check for though is that you’re not telling the machine to go faster than it actually can. If your laser configuration says, “don’t go faster than 2000 mm/min” and you tell it to go 4000mm/min, the velocity ramping will reduce the power by 50% to compensate.

So, check the settings here:

Look at the ‘S-Value Max’ setting found in the ‘Device Settings’ window and make sure it matches that value set in firmware. You would need to check the settings for $30 (Spindle max setting), should be either 255 or 1000, and the LightBurn “S Value Max” device setting has to match it.

Hi Oz

Thank you for your help. The problem was solved.

I changed $30 = 1000 to $30 = 255 and that fixed the problem. The Cuts window shows 20% Power Max. which is the default. I no longer have to set the Power Max to 100% to get the same burn. Oh and I set the Device to GRBL to GRBL M3 too.

BTW I did purchase Lightburn and I am very glad I did :slight_smile:


1 Like