HTPOW laser engraver not being found

So I have a cheap HTPOW laser engraver from Amazon. I’m having trouble getting it to connect to lsaergrbl or light burn. Both don’t seem to find the laser machine. I suspect it uses a different firmware than the standard but I’m not sure. Any suggestions?

This was discussed on another topic recently:

Best guess is that it’s not running a supported firmware. Would be interesting to see if it could be flashed with GRBL or something supported.

Hey man! So I actually had the same thing going on and I finally figured out how to get it going. First the controller is not compatible with light burn or anything you can only use the native software. Another thing I found was that I was having problems getting it to connect even with the native software. Some recommended I run a SST on it and when I run that it allowed my computer to connect to the laser but only while that’s running or else my computer can’t find it. I’m thinking about getting a new controller that’s supports light burn and modding the original laser into something that works with light burn just trying to see if anywhere has plug and play controllers or if I’ll be better off just biting the bullet and returning the laser and spending the money to get a better laser

I have no problem connecting to the supplied software. The only issue I have with the software is that while engraving it’ll just stop go back to rehome and act like it finished the job. Usually on bigger jobs. And will do it on the same spot everytime I rerun the same job.

Also I tried to run it with grbl and it wouldn’t connect

Hey it looks like the actual Wainlux JL3 Pro is on “sale” on Amazon for the same price you most likely bought the HTPOW. I’m returning the HTPOW and getting the wainlux since I’m their description they actually mention it working with light burn.

Note that the standard firmware for JL3 Pro is also not compatible with LightBurn. You’ll need to update the firmware.

A user here created a review of the laser:

Sounds like it’s on the usb so I’m assuming it wouldn’t be too difficult to update the firmware? As he mentions the mobile phone feature is an easy trade off for being able to use light burn. An extra step on a cheap machine isn’t too bad. I put together the HTPOW which is a rebranded wainlux jl3 so I pretty much know how to put it together

Should not be difficult as long as the firmware is readily available.

If that’s the case then don’t see why the upgraded firmware wouldn’t also work on HTPOW if you can get access to it.

Only assumption would be they use a different controller? I’ll have to look when it arrives and compare them. But I tried looking for the firmware and have been unable to find it

I would guess you don’t have the proper driver on your computer. This is the most common problem.

Have you run it at all with anything, like supplied software?


Supplied software works. Issue with the supplied software is that at a certain point it just stops engraving and returns home. Rebooted computer and tried everything. COM displays the device but nothing recognizes it other than the supplied software.


There’s a good chance it uses the ‘CH340 driver’ and I would attempt Baud Rate changes after the Manufacturers Software was working - which it is.

There are a few things that you could do to further inform folks here.
Was there an instruction manual with the engraver?

Is there any communication information defaults / presets in the original software? (this could inform set-up)

Can you post pictures of the engraver? Someone might be able to Identify it as being similar to or copy of something known.

if you can see the circuit board that the stepper motors plug into - an image of that can occasionally be informative as well.

I bought a super cheapo laser and reflashed the firmware. LightBurn works as expected.