I am a first time lightburn user and have bibo2 touch is it compatible and how to setup

I have a bibo 2 touch 3d printer with laser engraver attachment that runs flawless if i run inkscape but only issue is i cant fill objects using the jtech extension so i tries to switch to this lightburn softaware but when i run the gcode created through lightburn my laser is going on and off flashing and not burning i have a bibo 2 touch laser engraver X 214mm Y 186mm i dont know if i did not setup printer setting correctly or what but everything seems correct as i looked over everything mabe mh printer is not compatible with lightburn? But why is lightburn cuasing my laser to go on and off :thinking:
How can i setup and make lightburn work for my bibo 2 printer is there any precompiled profiles i can load settings also lightburn should really consider adding a wifi connected printer capabilities for the ones like mine so it can actually connect to the lightburn interface my printer will not connect or function with light burn either another issue i am experiencing no connectivity to print how can i fix this?

If you can get it to connect, you’re doing better than I have with my Bibo II. I can’t even connect to the controller…


1 Like

I actually cannot get it to connect either to my bibo mine does not connect either to lightburn i rsalky dont need it connected i van run fine with sdcard and gcode file what i did was just attempted to setup machine settings manually then i just simply ran a test file import png and place it in lightburn exported as gcode changed the ext from gc to .gcode and tried to run it my laser was not happy ot was doing disco effect kept turning off and on moving around not burning imag i dont eben think lightburn created the path correctly i run inkscape and its flawless but i cannot get inkscape to fill in my laser burn images they cone out as only traced like this so thats why i decided to switch to lightburn and cant even grt lightburn to work at all

LightBurn has a WiFi g-code streaming capability. Not all systems are compatible. It will be interesting to find out how the information for your 3d printer is bundled and sent wirelessly.

I have asked one of our subject matter experts to take a look at this thread.

This jtech extension for inkscape appears to be using M3 to operate the laser.

Have you selected GRBL-M3 in LightBurn?
If not, please select GRBL-M3 for your device profile in LightBurn and retest.

If you can share anything else about the firmware in the printer that would be very helpful.

1 Like

I have all the firmware information along with firmware files i will post them up shortly please come back and how does lightburn have wifi my bibo sends it own wifi signal i have to connect to likebi do with pronterface all i do is simply run the ip and port 8080 to pick up and connect you guys do not have this function anywhere in lightburn so it does not have wifi enabled connection

Here is the source code and it is open sourced on github
Here is bibo tesh support email for lightburn staff to contact bibo email support: braden@ourbiboDOTcom

Stock bibo 2 firmware file

Stock bibo 2 open source github link

1 Like

This is what i was told by bibo tech support braden they have an amazing tech team that is very helpful so i dont want to hear any excuses lmfao :rofl: :joy: :laughing: im just messing around but seriously you guys at lightburn need to get this bibo 2 issue resolved and the guys waiting one email away to figure exactky what u guys beed to resolve the bibo connectivity issue cuase honestly i will try that grbl32 whatever but i know 3d printers mostly run of marlin but ok if that still does the flashy laser disco light dances :man_dancing: i am not messing with lightburn and risking damaging my laser module testing your guys software whos gonna buy me a new one :wink: if it breaks my laser from all this irraticle off and on laser disco effect if u or your company can back up a replacment if im testing my own stuff that cant potentially cuase damage then yea im fown to keep trying but i need to burn an image not dance to disco lasers not burning images even when i export your gcode and place the files in repitier and do a live preview umm it dont look right just a ton of scribbles not even eligible to read crazy so yea idk i think u guys need to do a little more research and development on the bibo printer and ultimakers

Tell us how you really feel. :joy:

1 Like

Rite you know whats up @Bikemike lightburn just needs to get with the program and talk with the bibo 2 tech staff and get all issues resolved they need to email braden already and figure it out i even gave u guys all the file links and files for everything needed thanks :blush: :pray:

Just to be clear, LightBurn assumes no responsibility for your hardware and how you use it. You might be able to install a laser incorrectly enough to damage it or consume its lifespan at 100% power but there’s nothing the software could do to damage the laser if the hardware is correct.

I will ask if Marlin devices can be connected to LightBurn through the TCP/IP port.

Please provide a clear pic of the processor on the bibo. I may try to flash the software to a microcontroller to see if i can get it to talk.

Ive never opened it up so idk the mcu chipet number im sure of you email braden he can help answer all your questions

Then don’t. Demands don’t work.
You are asking the lightburn team to do all the work you should be doing.
Email someone? To get the info you have?

Did you download the 30 day trial from the LightBurn Website?
Some erratic behaviour is caused by a failed internal integrity check.

If you are willing to share the exported G-code files here, I’d like to have a look.

Another pile of information is available to us in LightBurn.
Click Help,
Click Generate support data.
open a reply here.
paste the big blob of nonsense into a reply here.

What exactly is the operation/use of the ‘debug drawing’ in the Edit menu?


It wont let me post gcode file here whats your email i can email those over now to you

Add .txt to the end of the file name.

Good call thanks here they are what lightburn generated

LIGHTBURN3.txt (252.3 KB)
LIGHTBURN2.txt (251.8 KB)

LIGHTBURN1.txt (358.2 KB)
LIGHTBURN.txt (358.8 KB)

I just generated another one and it still flashes how do i change the marlin to grbl32 or whatever i would like to try that one other guy suggested earlier i cant find it :thinking:

This might work.

I’ve been advised by several folks here that we won’t be developing “Old Marlin” - The Marlin build in the firmware link you shared had an embedded date of 3/18/2016.

I looked at the Firmware and according to the link you sent it’s a Ramps 1.3 EEB build. The Pinout information is in Configuration.h

The good news may be that, you have an Arduino Mega 2560 under the hood. You really need to check. Although a GRBL 32 is too advanced or new, you might be able to do this as a basic GRBL 1.1f or 1.1h Build.