I desperately need a referral

I’m hoping being a forum someone can PLEASE help me. It’s not a Lightburn issue but I don’t know what to do.3 days ago my 1 yr. old 80W CO2 Monport laser stopped working in the middle of job… It said water error but chiller was fine. Monport changed tech support from great to HORRIBLE. Does anyone know someone who is tech savvy.and offers their service? I am desperate. I have a business and orders to get out. I feel it’s an in the controller (Ruida) because it halfway starts or comes fully on and quits and says SYSTEM resetting. PLEASE - I need help ASAP TAHNK YOU FOR ANY leads!!

The water switch in the engraver is a flow sensor. If the water isn’t moving that will throw the alarm.

If the flow sensor goes bad, it can throw the alarm.

A loose wire between the flow sensor and the Ruida controller can generate the alarm.

It may be wise to twist the emergency stop button for good measure. If it’s latched down, twisting it releases it back to the ready state.

Can you drive and do you have a voltmeter? If you don’t, you should have one… you can get low cost models < $25…

Most of these Ruida controllers have indicators for you to observe.

This would depend on how it’s wired… The Ruida is probably correct in that it thinks there is no coolant.

You can have your chiller wired to the laser or most stock lasers have a pressure switch that pulls the input of the Ruida low (active)… In this picture, it closes the switch on the two pins, pulling the Ruida input low.

Look in the electronics cabinet and locate the controller… It should look similar to mine… Mine is a 6442g model… If LED 9 is not lit, it’s not active… If you have water flow, it should be red… if not the issue is before the Ruida, switch or wiring… If it’s active it may be a controller issue… This only take and instant to detect, so it might just be flaky.

Good luck


Thank you very much for your reply. My issue right now is that the laser partially turns on. The only red light on is 15 and a blinking 14. The red beam on the head is on and the controller says SYSTEM RESETTING and than that goes away.


Do you have a CW5000 chiller? They look like the one in the link below. If you do, chances are that the flow switch that others have mentioned has failed. This in a fairly inexpensive part that is available from several on-line vendors and looks like this:

It is a little complicated to replace if you are not mechanically/electrically inclined but is doable by a competent handyman. Where do you live, in general? Perhaps someone hear is nearby and could help.

If the WP led (9) is not illuminated you have a protection issue… It’s the switch, the wiring or something, but it’s not getting to the Ruida… That will produce that error… How do you know the chiller is working properly… what kind of chiller…?

First post

This is post 4…

Did the symptoms change?

What do you mean, partially turn on?

Did you fix the water protection error?

Since the laser is IR and invisible, you are seeing the pointer on the head… This is usually feed 5V and isn’t related to the issue you seem to have.

However, it should not show system resetting… Only time I’ve seen this is when there was a power fluctuation… I’m sure it can ‘reboot’ itself if that was a requirement, but I don’t know what else can cause this…

It generally sounds like the controller is acting up…

Do you have a good factory copy of the settings that you can restore?


THANK YOU for replying!!! Yes that is my chiller. I ordered the part from Amazon and will be here tomorrow. I do have someone to put it in.
Once replaced will that allow the laser to start? Because right now I turn on the laser and I get this (attached) - red beam on - one red light in cabinet (#15). Do I turn on the chiller first and then the laser? So sorry to ask more questions I am so appreciative - Thank you!!

If you diagnosed the issue properly it should…

The chiller needs to be on when you try to lase something (run a job)… the order you power them up should not matter…

I power the controller up as a general rule, do all my setup and framing, turn on the chiller and run the job… in the winter..

In the summer, the chiller is on for about 5 minutes to let it cool down before I put it to work… it gets pretty warm here in the summer…

Good luck


It is unusual that a water protection error would cause a spontaneous reset of the controller?

The water protection input pin at the Ruida is 24V, maybe the GND pin on that input doesn’t have the ability to properly sink what is likely a very low resistance pulldown.

1 Like

If you think the chiller sensor is faulty, and you know that the chiller is still working and you can still see the water is flowing through the tube, you can temporarily disable the water protection alarm at the Ruida, so you can continue to work while you wait until the new sensor is fitted:

Unplug the sensor cable at the back of the chiller.

With the laser on and connected.

In LightBurn, go to Edit > Machine Settings > click on the ‘Read’ button.

If the controller settings are read successfully, then ‘Save to File’, a backup of your settings.

Then toggle off ‘Water Protect Enable, Laser 1’, and click on ‘Write’ to upload this change to the Ruida.

Click on ‘Read’ again to check the update was successful.

Push the Reset button on your controller to restart it.

That should allow to to continue to use the machine, remember to re-enable this setting as soon as you can!

Temporarily disabling and disconnecting the sensor will also help troubleshoot your issue with the controller randomly resetting itself, which does not normally happen.

Note, the Water protection sensor may also be connected to the power supply for the laser tube, if that is the case then you still wont get any laser output and you should just re-enable the setting and put the sensor cable back to how it was - but before you do that try running a job anyway and although the laser won’t fire it will still be very interesting to see if the job goes through all the motions without the controller resetting.

1 Like

Thank you so very much everyone and Nicholas for this last message. Great info that is great to have from here on. I am prating this part will be the answer. if not I’ll be back here again.

1 Like


I’m back and stuck. I opened the top back lid of my laser (where the tube is and wcan not see where this part goes. I was told in the upper left corner. I have photos of both corners but I don’t see that I can attach them. I don’t know if these Chinese lasers have similar parts and layout in the back - but if someone knows what I’m referring to — any help would be appreciated.

Meanwhile I’ll try what Nicholas sent. The chiller is sending water and I see teeny tiny bubbles vibrating. in the tube

Are they vibrating or actually moving? They have to be moving at a pretty good clip…

You should be able to drag and drop a photo on the reply edit window. It limits file size to 4MB and some file types are excluded.

If you want to post a video, you can put it in your google drive, set it’s protection levels so anyone with the link can access it and post the link here.

Photos would be helpful…

Did you get a replacement switch similar to post 3 photo?

Don’t forget to tell us if the bubbles are moving, showing the coolant is flowing.

Here’s a video of mine with a thick additive to prevent freezing. It’s running 2/3 of the speed it’s distilled water speed… Just to give you some idea of flow rate.

Good luck


Ok – I found the part in the side cabinet.

Is the part in the thread going to work? It looks a little different.

I couldn’t see any water running in the video except at the end. I don’t have anything looking like pouring. But I have pinched the hoses in all different areas and I can feel the water running through it. I saw one small bubble rush by. It doesn’t trigger an alarm on the chiller but is that because of the sensor?

If I have the right part coming and goes in fine. The controller won’t be trying to reset because the sensor is working - correct? Do I need to hit the RESET button? I should run the laser and chiller for a while before running a job - correct?

Can you post a link to the purchased item? It looks ok, it should have two wires… flow meters have three.

If you are completely 100% satisfied that the coolant is flowing, through the tube, you can disable this as @NicholasL mentioned to see if it will run…

Anytime you disable a safety feature, you are the responsible one…

These are in edit → machine settings

I marked it in red… Mine is disabled because the input failed and I moved it to the door protection, which I have always had disabled…

You can at least ensure the machine will operate if this is the issue… It should run with this set to false.

It’s not recommended to operate this way… If you forget the chiller, you will lose the tube.

Do you own and can drive a voltmeter? They are simple and most of these issues can be solved with one, pretty simply.

Good luck


UPDATE – I think my laser is toast. Replaced the sensor. Was still getting water error message so we switched and hooked red wire to red and black to blue. The control finally came back to normal and I saw the last job I ran. But no cabinet light and no laser head moving. In the mean time we had the electrical cabinet open and only number 15 was lit and a blinking one next to it. It started smelling like “electrical”. And all of sudden pop the controller and the metallic box next to the black laser box blew out and smelled fried. both were very hot to the touch.

I’m so upset I’m afraid to ask what this means especially just after one year.

Is this from the flow switch?

It might simply be the low voltage supply that has gone…

Can you post a couple of photos?


My guy didn’t want to solder the ends until we knew they were good. It wasn’t easy to figure out which wire was which coming out of the cabinet. So this show them now disconnected.
The other is my cabinet. The left and right box each had a light on until the smell and pop.
I have now idea how to relay this to the Chinese person I was texting with. The sensor thing took forever for them to agree I was purchasing the right part (which wasn’t the one originally here in the thread). Thank you foe being so kind and replying. I am not handling this well with all the orders I have. The white controller box looks easy enough to install but I have no idea what is under that metal cage. What is that?

Oops I think my guy told me wrong when I wrote about the color wire. There is no blue that I can see. He’s left and was just looking at this again. I think he meant to say he didn’t know which red hooked to the black wire. But we didn’t keep it for long - as soon as it said system reset we stopped and changed it. and that’s when we got the last job I did when it stopped.