I have an AWC708c output question?

I have an AWC708c connected for a rudia controller The laser is not firing. What should the PWM voltage output be?

I assume you mean you have an AWC708c instead of a Ruida?

Does the machine operate, just not ‘lase’?

Is this a new machine… when did this start to occur?

The standard lps has only two control lines used by a dsp… some will also use the P (water protect), but it’s much more wise to let the controller handle this.

The pwm control goes to the IN terminal of the lps
The ‘Laser enable’ goes to the L terminal and is active low.

Will it lase if the ‘test’ button on the lps is pressed?


Yes this is a replacement for the rudia. When the laser turns on the laser heads move. The stops don’t work. What is the lps? The laser does not fire from the test button.
The laser worked before we shipped it from California to Wisconsin

Was this before the controller change?

It does not home on startup?

Laser power supply… the high voltage one to your tube.

Does they tube look physically OK.

No error messages in the machines console?


The controller was changed prior to shipping. No physical damage to tube.
Is there a way to track the where to high voltage is going?

Is there somewhere on this forum, that I can post to see if there are any people near Kalamazoo Michigan?

How do I write my reply Directly in your response?

It operates this way so others can learn or find the answer to a similar problem. Unless there is something that is private, we prefer to keep the communications public.

The real question was, prior to shipment was it working in it’s current configuration?

There are different avenues to follow depending on if it’s a new controller change or just a failure of something after shipment.


Yes, it was modified prior to shipping, and it was working.
Is there a way to trace where it is working and when it is not? I checked the LPS and the fan was blowing. Does that mean it should be sending voltage to tube?

Thanks for the help

This is very misleading/confusing as you no longer have this controller.

If all the wiring looks good, like it didn’t shake lose during the move, I’d look at areas that are most likely.

Does your machine have a mA meter and/or a digital meter on the lps?

A digital meter in the lps usually has a ‘lase’ indicator, you can just look.

  1. Do all parts of the machine get power, including the Ruida and motor drivers ?
  2. Does the machine console display show any kind of error message?
  3. Is the ‘P’ input of the lps grounded or does it go to the water protect switch?


Jack, thanks for all the help, and the patience. Like I said in my post we removed the Ruida controller and replaced it with the 708c controller. When I start the laser, the head goes toward the right then heads the back.
If I check the voltage on the 708c I get 5v ttl, and 2.5v pwm.

Cont. I worked on the LLP and now when I turn on the laser the fan in the LLP starts blowing. Does that mean it is sending power to the laser? I tried to fire laser and no luck. The laser has an amp meter.
I am pretty sure I have the door and water protect disabled.
Where do I go from here? Would it help to send pictures of laser display or anything else


Don’t know much about that controller, but it’s interface to the lps is the same for both…

There are two main signals and one that may or may not be used…

First is to check if the P terminal of the lps is wired to ground. This is the water protect input to the lps. If it’s not wired to ground… speak up…

The main two are the pwm and the laser enable (L-ON1 on the Ruida)… this goes low when it’s supposed to lase. The pwm only controls percentage.


Jack, we are making progress. Let’s see if I can explain this.
Now when I load a file and I press the laser button it fires the laser. When I try and cut a file the laser moves like it cutting the file, but the laser does not fire. It will however fire and cut a box if I go to the menu in the Laser and pick the option cut box meaning the framing box.
Thanks, Bruce

Usually ‘framing’ refers to moving the head around the cut/engrave area without it lasing. So I don’t understand the ‘cut box’ meaning…

If the laser fires via the machine console, it’s obviously controlling the laser.

Double check your power levels on the laser and ensure they are in the lasing range of your machine. Low percentage power levels may cause a tube not to lase.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.