I need help with my new red-black Ruida 500x700 size laser

I received the laser machine last Friday night. I have it all setup and when I started for the first time the laser head went to the upper left corner and it didn’t stop trying to continue moving and producing a noise. Like it is forced to continue moving. If I press the ESC key it stops. If I press RESET, it does the same movement again. So I turned it off. If I press the arrows keys on the key board, the laser head moves in the opposite direction of the arrow that I pressed with a very hard and noisy movement in both axis (X , Y). If I press the HOME key in the RDWorks software, the laser head moves very fast to the right down corner and bumps very hard continuously and I need to shut down the machine. I am really concern about this.

I made a default reset of the machine, but it didn’t help. The same problems continue happening. When the laser head gets to the upper left corner bumps many times, then stops and on the screen shows X=0, Y=0 and Z=3000. When I pressed an arrow to move the laser head, in any of the axis the value of the position of the laser head on the screen changes and the laser head doesn’t move until a moment when it starts moving in the opposite direction of the arrow I am pressing. When I move the laser head back to the upper left corner the origin is not zero on any of the (X,Y) axis.


I hope someone knows what is wrong with my new laser.
Thanks.

When it powers up, the controller is seeking the limit switches that indicate the home position. The orange block in this picture is one of them:
image

The rail of the machine should have a metal piece that slides directly above that block, and the block detects it to tell the controller it has reached the limit of travel. Is this a 2nd hand machine, or new? If new, I’d contact the seller.

Thanks for respond, is a new machine

On my red and black machine, the “home” position is the upper right - sounds like that isn’t set properly and it is trying to “home” where there aren’t limit sensors to stop it. If it is also doing it on the Y axis, perhaps the dimensions are not set up properly on the machine. Can you take a snapshot of the machine settings and post the along with a picture of the bed?

Mine did the same thing when I reset my ruida to factory default. It was because the steps need to be calibrated. On mine the default was 3.75 and the correct setting was 30.01. Also had to enter the correct breadth and height. Which for me was 700 and 500. After I did that it was homing properly and recognizing the limit switch. I also adjusted the max speeds for each axis

1 Like

Justin. Thank you for your comments. I don’t have any experience with this equipment. If it isn’t too much asking, could you let me know how I calibrate the steps for my laser? How can I enter the correct breadth and height? In my case is 700 and 500. (At least I know something) Thank you again. I hope you can help me.

Here’s a good copy of my config for this machine:

good 500 x 700 RD Works File

I have several of these machines… Here’s a good config file// It should get ya’ going. Home is in the top left on this machine. There is no end stop on the right, so it’ll just slam into the rail…

open Rd Works… Go to file / vendor settings

Your password is RD8888

Read your machine data… Then save it to your desktop.

Then open My Config, and then write it to your laser.

From there, you should be good to go back into light burn and do your thing…

Just make sure your machine size is set right in Light Burn. the controller stops the head at it’s soft limit. so if it’s still hitting at 700, try something like 690.

this should get you in the ball park. if it doesn’t suit you, you can just load your config back to the machine.

Holler if you get stuck!

This is how I got my info from the YouTube and this forum

I haven’t been able to find a calibration tool in the new lightburn yet. Is there one?

I always just run to RD works to set the steps, then work in lightburn.

I have learned that cutting larger test objects yields a more accurate calibration. Get a bunch of cardboard, or thin plywood, and cut your test squares as big as you can.

100 x 100 seems to make a larger deviation when I do big big cuts… But cutting like 500 x 500 makes big cuts accurate, and small ones super accurate!

Good morning, i restore the vendor settings and change the polarity on the Y.
right now is working good.

1 Like

Thanks everyone for your help.

I was wondering about the polarity. How do you determine what polarity each axis is?