I'm new to lasers. I still cannot get it to work like it was advertised. I need help

I am having several difficulties. I am about to run out of the LightBurn extension license. I am NOT a professional printing or lasering house, I am a grumpy old home hobbiest doing nothing commercial. I just wanted to find a hobby for the time I have left. Unfortunately, I am not wealthy enough to buy a non-Chinese machine. Perhaps you cannot teach an old dog new tricks because on my budget I’ve bought several Chinese (or Chinese-containing) items. That being said, I have a major lasering problem:

I bought this 60w CO2 laser off of Amazon. The seller has been VERY slow (after they stated they had 24/7 support with ‘no worries’)(yeah, right!)(but remember, I must be a stupid and grumpy old man). It was supposed to have a 16" x 24" cutting area (it seems to really be about 14.5" x 23.5". The Ruida 6442 controller has some very weird behaviors. Mainly the buttons don’t do what I see on many of the dozens of videos and hundreds of postings that I have seen or read. I can push EITHER the left arrow or the down arrow and the laser head moves BOTH to the left and down SIMULTANEOUSLY (i.e. southwest). The [Esc] key does what a ‘framing’ should do. The [Origin] key starts it lasering; etc.

I have tried cycling power. Pressing the [Reset] makes it home. The [Z/U] opens the menu but then the arrow keys are berserk. Am I just too stupid to do this or follow the directions or is there something really wrong here. I’m about to just give up on the whole mess. It is VERY frustrating and I don’t need that!

Nevertheless, thanks for any help from you guys.

You have one reference to the positive side of things. Your machine homes. My 500 x 700 had a failed inductive travel stop during the first week! I have spares now.

If your machine homes to the upper right corner, it may be configured in the same manner as mine. Do a search to learn how to back up your controller configuration to a file before you begin to tamper with settings within the controller. Once backed up (even though they may be incorrect!), you can proceed to tamper with the settings.

If your home is the same as mine, I can share the configuration file for you to load to your machine. This will let you determine if it’s in the config or if it’s in wiring or elsewhere mechanical.

Your profile is ‘private’ so I have no idea how long you’ve been on the site. If you post and don’t allow people to see what kind of machine you have, it could be a problem. I know you mention the machine type, but you will have to repeat it every time your post… Click on my icon and you will see how it works… just a suggestion.

It’s Chinese so the work area is in CM or a ‘6040’ type, 600mmx400mm.


Can I assume it’s a new machine? Did it always do this or is it a new development?

I haven’t seen a Ruida that didn’t respond to the keypad or act as you describe. Your only choice may be back to the vendor to see if they will do anything. What vendor was it?

This is why many people pay a few bucks for a supportive vendor. OMTech isn’t what I’d call super responsive, they do get back to you and generally make things right. Amazon will pressure the vendor, don’t wait too long or you’ll lose that window of opportunity.


You could check to ensure the machine console it properly connected to the controller itself. I doubt this is a problem, but there is nothing that I know of in the configuration that would cause this issue, fortunately.


Can you control it properly via Lightburn? I.E. does the arrow keys in the ‘Move’ window have the correct response? It’s possible it’s the console hardware that has the issue.

If you go to “Edit → Machine Settings”, you can ‘read’ the controller (which it does by default). Before you do anything else, use the ‘save’ button to ensure you can recover if you ‘forget’ what you changed… It’s also a good basis for the starting point.

I think it’s a controller/console issue … start a communication with Amazon NOW, let then deal with the vendor at their end. They have the power to ‘stop’ the business. If you get a fix, say it’s working and cleared up. Rather than a ‘non working’ machine that needs a $400 controller…


I wish I was more optimistic, the last thing I usually advocate is changing hardware, unless I’m pretty confident. I wouldn’t know what else to advise you to do… except check the console/controller connection. I don’t even know if you can get the connector miss aligned.

If you mean the free trail, send your ‘key’ to support@lightburnsoftware.com and explain that you’d like to extend the trial. Don’t post your key anywhere here.

They are great to deal with …


Let us know if it works via Lightburn

Good luck

:smile_cat:

Hi Jack, sorry I’m brand new to this forum as well as to laser cutters. I would be happy to update or upgrade or edit or even start anew with the forum. It is just not my priority now. My laser machine (a new one) is from Wouenuit on Amazon (still listed today) and it has the decal on the front saying it is made by Zikebtuy and it is supposed to be new (just over 1 month ago, so it is too late to return it via Amazon). I did contact Amazon and I got a run-around. They are willing to send a message (to the seller) but that’s about it after they tell me to ‘work it out with the seller’. It is supposed to be 60 watts and have a 16" x 24" bed (or 300x600mm). The X is 600mm (nearly) but the Y is way short due (I think) to the placement of the Y-axis limit switch, which IS in the back right-hand corner (like Freds) against the metal frame (so it wouldn’t lend itself to relocation, also since it senses the linear rail slider). I have already done the [Read] from the controller and the [Save] to a file (I have several). I have also tried taking the original .lbset file and writing it. The software always reports ‘success’ (and I suspect that is all good) but the Ruida arrow (and other) keys still act weird. Being that it is a “new” machine and that it is under “warranty” I am reluctant to ‘fiddle’ with it too much. It is in the opposite end of my house so I never use the PC application (LightBurn or RDWorks) to move the head, I only ever have moved it via the arrow keys directly on the Ruida console of the machine. I will try a measured move from a known position and then go and look to see if it was correct (X_only and Y_only), in separate attempts.

Can you suggest any alternative controllers or a good source for Ruida parts even if I should not have to fiddle with it as a new machine with a 2 year warranty ?

Either way, I’ll reply with my results.

Thanks,

Daryl

Hello Jack, I did try using LightBurn to ‘move’ the laser in only the X and then only in the Y directions. I can [Get Position] in LightBurn. I can also use the ‘move’ tab and the left,right,away, front buttons surrounding the little house icon on that tab to move the head properly. I can even set a ‘move to position’ and set the distance and speed. These all seem to work properly. WOW, the machine will even move straight left or right or forward and rearwards. But the controller arrows and other buttons are still very goofy. Unfortunately this machine is in a bedroom across the house (we have a ‘split’ floor plan) and so I have to go across the house to see if anything happened if I send it from LightBurn (I’m connected via ethernet to the machine, no camera). The X and (independantly) the Y moves seem to be very close to calibrated. I told it to move 5.000 inches and the [Get Position] returned a new position that was 5.001 inches (I’ll be happy to write that off to rounding errors right now). I went to the machine and it looked correct so I didn’t get out the indicators to check any further.

This all seems to point at the Ruida. It’s unfortunate but this can give a bad taste to the ‘laser cutter industry’. So, is it then not uncommon for a Ruida 6442 to be somehow messed up ? Is there a solution or should I try to get another one? Can the keyswitch/display unit be changed by itself or is it the entire Ruida system or just the Ruida box inside the right-side cabinet?

Thanks again for you help !

I’m assuming the below is your laser? With the buttons working the way you describe I agree try to get a replacement controller from the seller.

Jeff, Yes, that’s very very similar. The pic on Amazon (of mine) does not show the Zikebtuy decal but when the machine arrived here it looked like your pic (with the decal on it). Yeah, it’s looking like the Ruida controller it the problem. Unfortunately this is a brand new machine and I bought it (probably naively) thinking that since it was ‘new’ with a ‘warranty’ and from ‘Amazon’ that it would be a safe bet.

NOT !!! Oh well, I guess that’s what dumpsters are for.

Or, if I get a replacement Ruida expecting a different result am I insane or even more naive ?

Amazon should help you. You could always return it.

Amazon “should” help me. But they will not (other than to tell me the item is not returnable and that I should ‘contact the seller’.

Anyone need a boat anchor and willing to crate and pay for shipping ?

It’s probably something simple. Cloudray has replacement keypad control boards for certain controllers. Might try a cheap fix before throwing in the towel.

I would google, control panel for your type of Ruida, I’m sure I saw one somewhere that was just the panel.

Where do you live?

I suggest you calm down a bit and realize you are not having a good experience with this and that’s abnormal.

These are considered one of the best controller, there are millions of them out there. They seem to built tough as I’ve know many people that have abused them and they still work.

I’d look around, like…

:smile_cat:

Bronco, if you have an iOS device (Apple stuff), you can download a Ruida control application that works with your home network, especially since you have a wired network connection to your controller. The android version requires a severe payment, but the Apple one is free. Look for Ruida ACS in the app store.

It allows you to do all the functions on the panel from your phone or tablet. If you’re able to make things work from within the LightBurn software, it might not be the controller, but might be the panel, a good bit less money!

Hello Fred, thanks for your suggestion. I guess the way I look at it is that, while the iPhone or Android apps may be a nice accessory, the main user interface should be working properly. If the apps worked then I am still stuck with a main panel that does not work. I.e. it’s a ‘workaround’ but not a solution. Heck, I just found out that (by running back and forth from 1 end of my house to the other) the LightBurn software will ‘move’ the laser head in what looks like the right way. I could cut the floor out of my car and make it into a Flintstone-mobile (now I’m dating myself, sorry) but that would not fix a non-functional motor. Nevertheless, thanks for your reply.

Hi Jack, Thanks again for your reply. I live in Florida (I used to live in the SW). There have been several suggestions. Yes, yours to ‘calm down a bit’ is good and thanks, but, unfortunately everything I touch seems to be the ‘anti-Midas’ touch. Consider a Gaussian distribution. Near the center (say within about 2 or 3 sigma, most things are ‘normal’. Then consider beyond 3 or 4 or even 6 sigma and things are pretty much always ‘abnormal’. That’s me. I even once worked at a place where, when they were looking for how well something held up, they would say ‘Let’s get him’ (me).

In reality I have sent another message (via Amazon) to the seller about this. I should wait and see if they will do anything beyond telling me to wait (I ordered this machine nearly 2 months ago). I’ll have to make up my mind after that as to what to do.

At this point I’m not sure if it is in the switch/display panel or in the main controller box in the right-side cabinet. So I wouldn’t even know what to buy, let alone if I was willing to take the trouble to do the work to replace it. This machine also came with an errant door cover protection sensor (which is why I disabled it under 'Vendor" settings {after having saved an original backup}). They have only told me that when they get it they will send it to me. That was weeks ago. Meanwhile, this thing is not a good hobby for me. I guess the LightBurn extension will expire soon. They were good enough to extend it for 2 weeks but I can’t see spending $120 for software if the machine does not work properly.

I had to get a replacement part for my laser. They were slow to respond and it took awhile to get it. The part was shipped from China. Lots of sellers on Amazon are located in China.

My suggestion was to help you troubleshoot and isolate the problem. It appears that you may have a good start on that, despite the sneaker-net aspect of your results.

Don’t say that around the airport :crazy_face:


The link I sent you was $99 for a new controller console. Seems like a low cost option…

Did you look and see if the panel is properly connected. ? Seems to be just a plugin system…


IMHO, I’d replace the console. If the controller is working via Lightburn, I’d think the controller itself is probably ok…

Here’s a link to the Android Ruida remote. Used it a little then went with the Pi…

Good luck

:crazy_face:

@Fred, sorry, I just didn’t get it. I guess I’m trying to do something with unreasonable expectations.

@Jack, I don’t go to airports much any more (I’m a licensed pilot but my Dr’s told me I cannot fly any more, which is why I moved from the SW to FL (lower elevation). BTW, I’m guessing now that the main processor for running the steppers and the laser are in the Ruida box that’s in my right-side cabinet; right ? And then I suppose there is another (perhaps even an MCU) in the ‘console’ that scans the keys and runs the display; am I guessing right ? Or, is that all wrong or irrelevant ?

It’s late Sunday night now and I’ll be tomorrow before I can see if the ‘console’ is properly plugged into the main Ruida box. I’ll reply here then. Thanks for your help!

I’ve never seen inside one of the consoles, but I would assume it has it’s own controller and communicates with the Ruida.

The Ruida controls the signals that tell the motor drivers what to do. Here is a general wiring of the 6442g (from that manual). Enable, direction and pulse are what the Ruida controls for each axes.

If you purchased just the control panel, you could just plug it in and see if it works. If it fixes it, then change it out… It’s only a couple screws…

On the bottom left of the controller, it’s labeled “HMI”, same orientation of the controller as the diagram, that is where the control panel plugs in. It’s hard to see the black cable that goes up to the console from there.

Good luck

:smile_cat:

New guts to the keypad is $13 at cloudray

1 Like