Image shifting? What happened here?

Hi ladies and gents,
I have a xtool d1 10w and I tried engraving this on my canvas and I walked away for a little bit and came back to see my image kept shifting in different parts as you can see in the photos? Any ideas?

Here are my screenshots, any idea?

At the beginning I framed it and it said due to overscan cut might be out of blah blah, I ignored it, it all started great and then I came back to two shifted spots one almost in the middle and one up top… ?



That usually occurs when the machine has lost it’s position. The image is good, just ‘moved’ over or shifted, as you put it.

First is to check that the actual moving hardware is working OK. This looks like a set (grub) screw came loose and the motors rotated without turning the pulley…

Without power you can move the machines head and see if you can ‘feel’ something loose…

Does this only occur randomly?

:smile_cat:

Hey jack,
I haven’t engraved anything this big before but never happened until today
I re tightened the belts
Checked the other components and re tightened the screws
I didn’t feel like they were lose but I re did it all anyways
I’ll test out again now and get back to you

You don’t think it’s a setting I messed up on lightburn?
High dpi or something? My dpi was 314 when I ran it through imag-r

I am curious it happened coz I ignored the warning before I started the engraving? The one where it said might be out of bounds but it wasn’t coz I used frame and it was all in there hmmm

60 in/s is absurdly fast. I don’t know how this is actually even working. I suggest you dramatically slow down… to something like 4 in/s if you insist on using in/s (typically mm/min is what you’d use for a diode laser).

1 Like

Anytime you get a warning, know what that warning means and who ‘sent it’ and what it’s going to cost you if you continue…

Was it Lightburn or the controller in Lightburns console… that you saw the warning?


Doubt that 314 dpi would be an issue here…

@berainlb - looked at the speed, but didn’t catch it … it’s probably just running at the controllers set max speed for that axes.

:smile_cat:

Likely, but I assume it’s faster than the motors can keep up and likely missing steps on occasion.

I’m still new to this and learning
So what suggestions do you have for me to get better settings ? Thank you !

I’m saying dramatically reduce your speeds and try again. Perhaps on a less precious material. If you push your motors faster than they are capable of going it can result in missed steps.

So at a minimum you have a cut setting issue.

If you are absolutely certain you have no mechanical issues then this is the most likely culprit. However, this looks to me most like a loose belt scenario. It could also be a situation where pinion gear is not secured properly to the stepper but doesn’t seem to match the symptoms as much.

1 Like

How should I change it and if it can’t keep up why its an option I’m confused a little thank you I’m learning like I said
The reason why I used those settings is coz I saw a YouTube video where the guy used those settings to burn on a canvas that was spray painted like mine and his came up perfectly, same machine but maybe different settings

I checked the belts, actually loosened them up and then re tightened them and then I just engraved this image on a wood, no shifting but speed at 3.5 … so maybe it’s a speed issue? But the guy I watched did use the same settings I used… so idk :man_shrugging:t2: something is tricky here

It’s almost certain that he was using different units than you.

60 in/s is 91,440 mm/min. Typical units for diode would be represented with the latter. xTool claims a “routing speed” of 9,600 mm/min so that gives you a sense of how far off the speed setting is.

There are no limiters for speed or power. What you ask of the machine it will attempt whether or not it’s capable. Similarly, if you ask and insist that it run into the side of the frame it will dutifully do so unless you have other safeguards in place.

These are robots with lasers on their head. They demand some care and attention to operate and shouldn’t be treated like a typical consumer device. Better to think of these as semi-industrial devices with very few safeguards in place. There are many folks that have had very serious fires from both proper usage as well as malfunction. A failed job with laser continuing to run is a common occurrence. Please do not assume that anything that can be set is safe to use and do not leave these unattended without precautions in place.

It’s possible that Laserbox Basic is hard-coded to some of the limitations of the device and constrains you that way but I’m not familiar.

That makes sense! Much appreciated your explanation!
I decided to run my machine vertical too but check this out, horizontal was perfect and now it looks it messed up, I just realized my right side kind of kicks like do you see it, my left side goes smooth and it looks like my right side gets stock and like kicks and moves? I don’t know if that makes sense

Blockquote

Did you intend to include a photo? Or if not, can you attach a photo of what you’re talking about?

Tried sharing the video it wont load

Vidoes can’t be posted here. You’ll need to upload to a thirty party cloud platform and link here.

I hope you can see it it’s like left side moves smooth right side lags for like 0.0… seconds and slides and keeps going. Never realized that, maybe I just messed it up after I re tightened the belts ugh

I can’t really see the kickout that you’re describing but it’s possible that the left and right are askew which could cause what you’re describing.

Reloosen belts, push gantry all the way back so both sides are resting equally against the back frame, then retension belts being very careful that you don’t pull gantry away from frame unevenly.

Also, keep in mind that Y speeds will necessarily be much much slower than X speeds. This is due to the huge disparity in mass between what needs to be move in their respective directions.

I’ll try that and get back to you it’s like left side doesn’t move even at the same time

I mean look at this w is fine coz it doesn’t travel up and down much but once it starts going up and down further distance …

Actually I disagree or don’t follow.

Every machine I have has a maximum speed for all supported axes that it will not exceed. This is for grbl.

The same in the Ruida, which is powered off, so I can’t read the configuration.

Laser power (related to pwm) can also be limited via the power settings of the controller, at least in the Ruida.

If this is running too fast, I’d suspect it was shipped that way…

:smile_cat: