Image upside down and back to front

laser is back to front and upside down after i put the laser back on and this error has occurred

My machine is mysweetie 3018. I first used carving then the laser, laser was a great success, however I went back to carve for a project and when I come back to my laser this fault appeared. My saved designs loaded correctly but the home was the complete opposite to my screen,I did a trial run and found it was indeed upside down and flipped. I have removed all software and reinstated the software, still no change, I followed your forum and tried without success to solve the issue .I really need help. I’m very new to this and bought your software, can anyone give a step by step idiots guide to sort this out please

This section of the documentation is worth review, look for the part explaining how to set up macros to change between milling and lasing. Common Grbl Setups - LightBurn Software Documentation

And this post is for the setup of the 3018 system, also worth review.

Update us if you are hitting any snags along the way, and we can go from there. :slight_smile:

Thank you, i have gone through your guide and everything seams ok, however the laser lights up but no burn as well as back to front and flipped, (the laser works on GRBL but this is also flipped and upside down I put my computer back to factory settings to see if that helped. my sweety 3018 pro, i can see no writing on the clear plastic controller. what setting should i follow as the links give various machine settings can you give me a $$ list of what i should have because everything seams ok? Homing cycle is not enabled in your Grbl settings.
Starting stream
[MSG:Pgm End]
Stream completed in 0:05
$$
$0=10
$1=25
$2=0
$3=0
$4=0
$5=0
$6=0
$10=0
$11=0.010
$12=0.002
$13=0
$20=0
$21=0
$22=0
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$100=800.000
$101=800.000
$102=188.976
$110=1000.000
$111=1000.000
$112=600.000
$120=30.000
$121=30.000
$122=30.000
$130=260.000
$131=158.000
$132=34.000
ok
are these correct

You may not have the machine Origin set correctly for laser work. Device Settings - LightBurn Software Documentation

image