Importing DXF shows nothing

I’ve tried importing a very simple dxf created from CADKEY (might be the problem as it is antiquated) but when I import, nothing shows up. This thread right here seems to be the same problem but nothing seemed to work here. .DXF import and nothing happens.

I tried just importing a screen shot but obviously it assigns thickness to the lines which creates more work for me.

Any suggestions as to why it won’t show anything upon import? I’ll attach the file as a .txt if anyone is interested in trying.
rainbow.txt (6.4 KB)

Are you certain this is in DXF format? It looks like a binary format, possibly AutoCAD format.

I just saved in CADKEY as AutoCAD DXF and the file extension was that before I converted to txt…

My suspicion is that it’s a binary DXF (there are two types of DXF format: binary and ASCII text). I’ve tried it in CorelDraw, 2018, DraftSight, DWG TrueView and an online viewer but they all open as empty.

OK that’s two people now. I’m just going to assume you are both correct. I cannot find options to change this so I’m just going to abandon it. Maybe try in a newer system.

Thanks to you both!

Just out of interest, would you be able to attach the CADKEY file to see whether we can do anything with it?

I was able to use an online convertor to convert DXF->DXF.

1 Like

The layer was “frozen” - unfreeze it, and you can see the rainbow


Aha!! Well done, I didn’t spot that!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.