Importing from NAS on Linux (Mint)

I just got LightBurn and I can’t figure out how to import files from my NAS. I’m running Linux Mint, and I can see the drives in the file explorer. In file explorer, I get an option to view network drives and I can browse by folders without issue (after I log in). I don’t have that option in the import dialog in LightBurn. I can’t even drag the files from my NAS folder into LightBurn for some reason. I can’t find any mention of this problem here or on google, so I’m guessing I just need configure something. I probably need to spend some quality time with the terminal. I have very little Linux experience, so please be nice. :wink:

Thanks for your help.


Zack, welcome to the forum.

I don’t really know how Lightburn handles it’s files. Some software just doesn’t implement any kind of remote drives.

I’m hoping @LightBurn will pop in and advise us all. I have some of my files done with symbolic links but I think that’s different that a NAS type of connection.


Thanks for the reply. What is a symbolic link? Does that work on Linux? could I make a symbolic link to a folder on my NAS?

I would like to be able to design my projects on my main PC in the house, throw the files into the laser file on my NAS, then open the files on the PC running the laser. I suppose I could create a shared folder on the laser PC, but I don’t know how to do that on Linux and I would like to be able to work inside while the laser PC is off.

What network sharing protocol is the NAS configured to use? I assume SMB but please confirm.

I don’t believe LightBurn has any in-built network share code so relies on OS functionality for that.

  1. You could either map the share in Linux so that it appears as a regular folder. This will almost certainly work
  2. I’m guessing you can dynamically reference a smb share from LightBurn but I haven’t tried this.
    Can you try this name convention from the LightBurn file dialogue to see if you can connect? Replace the italicized parts with your actual user, server, and share names

If none of this is making sense can you take a screenshot of your NAS share setup and paste here? Please obfuscate any sensitive information.

I have a symbolic link from my home directory to a different drive for the basic directories, like Documents. Yes I run Ubuntu.

lrwxrwxrwx 1 jack jack 33 Aug 27 2020 Documents → /home/jack/mnt/dev-test/documents

is the directory listing from ‘ls -l’ It’s identifying Documents as existing at /home/jack/mnt…

Never have tried to do that. Type ‘man ln’ and read about it…


The NAS is running SMB and FTP. I think there was a 3rd thing that showed up too, but I can’t remember (maybe it showed a DLNA server). I assumed that me connecting to the network drive and entering my credentials mapped that drive. It shows up on my desktop. Is mapping the NAS folder something else? I can try directly connecting tonight. Will LightBurn remember the last opened folder, or will I have to type that in every time?

I’ll have to look into that, thanks. I’ve messed around in Linux a little, but mainly just things like a RetroPi, a XBMC (Kodi) box, or Octoprint. Nothing too esoteric.

Where did you do this? A screenshot would be useful especially of the mapped drive configuration from the Linux side.

From what I’ve seen LightBurn defaults to last used folder. But I haven’t tried this in Linux or does this through a share. I have saved to a network drive both from Mac and Windows before though.

Try one thing. Open a terminal and type “mount” and copy the output here.

I’ll have to do this tonight.

The way I accessed the drive was to click “go” (I think) on the menu pane (where ‘File’, ‘Edit’,… are) of the file explorer window. The sub menu had “network” as an option. Clicking on that showed my NAS several times over, once for each protocol.

What edition of Mint are you using? Cinnamon?

I actually don’t know what version it is. I bought it from a goodwill computer store, so I actually didn’t choose the OS. I’ll add that to my list of things to check out tonight.

thanks for all the help.

Sounds good. I’m actually impressed that Goodwill sells computers with Linux. I wonder if they reimage them or it was donated that way.

They wipe and reimage them, unless they have windows 10 already on them. They also tear apart laptops to remove the screens. They sell all kinds of random stuff. One time I got a stack of Cisco routers, level 3 switches, and 24+ port dumb switches.

If you think that’s crazy, I actually got my 700x500mm 80w laser from a habitat thrift store. I wasn’t expecting that. I just couldn’t leave it there in it’s sad state.

Also, not sure if I’ll be able to check out all those things tonight. A thunderstorm just took out our power.

That’s amazing about Goodwill. I donate there all the time but hadn’t checked the stores. You may be using my level 3 router. Haha.

I need to find a CO2 laser at habitat now.

Sucks about the power. Whereabouts are you located? Hope you’re staying safe.

Little Rock has a massive goodwill warehouse/outlet/office building that has a computer store in it. The normal Goodwill stores price electronics way too high, and rarely have anything good.

I live in central Arkansas. It was just strong, but quick, storm. The storm has passed, but that doesn’t fix the power.

I don’t know about Mint but other Linux versions often have an SMB configuration panel in the Computer Settings area which lets you link a network drive into your local filesystem. Once connected it will look like the network drive is local to all applications. Might be called Samba Share, SMB Share or Network Drive Share, etc.

Your file explorer is probably using an SMB plugin which only exposes the network connected drive to that file explorer application.

Thanks, I’ll look into that, now that I have power again.


After working on this all day today, I finally figured out the problems.

Doug, you were right that “mounting” a drive in Files is not the same as mounting a drive on a system level.

I had several issues caused by my randomly generated password containing characters Linux doesn’t like to see mid terminal command.

If anyone has this issue in the future, here is the fix:

  1. create an empty folder you want to mount the NAS drive to.

  2. create a text file that contains the credentials for your NAS. Format it like so:


  1. edit /etc/fstab and add a line at the bottom that tells your computer to mount the drive on boot. This line references the credentials text file you just created.

This is a helpful website that walks you through everything:

1 Like

After all that, it still didn’t work fully. This solution doesn’t allow you to write to the NAS drive.

The solution is to have the line you add to /etc/fstab follow this format:
//[IP address of NAS]/[folder name] space /home/[user name]/[mount folder] space cifs space credentials=[credentials file location],version=1.0,uid=1000,gid=1000 space 0 space 0

The uid and gid parts change the owner of the mounted drives to the first user created (you may need to change 1000 to something else if you have multiple users). Apparently this site compresses multiple spaced, which makes this really hard to read. I added “space” where you add a space for clarity. If you do this, it should work (it finally did for me).

here is the censored line from fstab with proper spacing:
//###.###.###.###/@@@@ /home/@@@@/NAS cifs credentials=/home/@@@@/@@@@,vers=1.0,uid=1000,gid=1000 0 0

1 Like

Way to power through after suffering in silence. It’s been a while since I daily drove Linux but I feel like I need to try Lightburn on LInux at some point. Maybe once they make the port to Arm.