Incorrect Framing results in Ver 1.1.03

I am facing an incorrect framing path (simple rectangle) when using absolut coordinates. The laser head starts at 0,0, is moving to the location of the object, but then stopps for whatever reason. Pushing the Frame button again will move the laser head from the stopp position to the next point, then it stopps again. Pushing the Frame button even again will then start a full frame cycle, by starting at the 2nd stopp point and finishes at the start point. Does that mean that I have to always push the frame button 3 times from now on in Ver 1.1.03 in order to frame an object onces?

Thank you for your support!

What OS do you use, and how is the laser connected to the computer?

I am using Mac OS 10.13.2 as well as Win 11 home with the same result, connected via USB. The farming used to work just perfect prior to Ver 0.9.24.

The newer versions of LightBurn changed how USB connections are managed, so they’re now “temporary”, IE, only connected when needed, then they disconnect again. This is also how Ruida software works.

MacOS has always been a bit weird because of USB driver issues, but it’s extremely rare to have problems with this on Windows. Can you try installing the newer driver from this page on your computer to see if that helps? There’s one for MacOS, and one for Windows:

Thanks for your support!
I have installed the USB driver for Mac. Unfortunatly it did not help. It´s still the same effect than before. Now even sometimes the framing function only finishes two sides of the rectangel instead of 4 and never travels back to 0;0. What kind of options we have to fix that?
(PS: buying a new Mac is no option for now (unfortunatly))

For the Windows side of things:
After checking with the PC I have to apologize to you deeply. Things are working just perfect. It turns out that we have had an internal communication missunderstanding. I am verry sorry again, things like this should not happen and better checked before they get posted. Learned the lesson! :smirk:

If you can, Ethernet communication is the most reliable channel for Ruida controllers using Mac and Windows computers.

Dear Rick, thank you for pointing me this way!
I certainly will have a look into that if this is the most reliable channel for Ruida controllers.
Since I am more like a USB-plug-and-play guy… may I ask you for a source how to set up an Ethernet connection properly? Also: Since the windows side of our company does not cause any connection trouble using USB I would rather like to keep it that way. Now, will it be possible to use both connections next to each other depending on the type of computer that will be used? Or does the Rudia controller nedd to be set up in a way to accept eigther USB - or Ethernet? PS: We will never have both computers connected to the controller at the same time.

Thanks again for your support!

1 Like

You can use either/or, and it won’t cause problems. I have machines set up here that use the USB for the Windows systems next to them, and Ethernet for more distant Windows / Mac systems.

I’m still not fully convinced that the MacOS connection troubles aren’t somehow my fault, or a weird issue with the framework we use, so I’ll keep trying to figure out what’s happening. Unfortunately I have yet to be able to reproduce the problem on any of our Macs in-house, which makes it basically impossible to figure out if I’ve changed / fixed anything.

Understood, thank you very much for letting me know! Please let me know if I can assist you with my Mac in finding the issue.

2 posts were split to a new topic: X-Y Slop Over (framing issue with Ruida)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.